Firefox doesn't remember the search engine with non-ascii characters as its selected engine

VERIFIED FIXED in Firefox 2

Status

()

Firefox
Search
VERIFIED FIXED
12 years ago
12 years ago

People

(Reporter: kohei, Assigned: kohei)

Tracking

({verified1.8.1.1})

2.0 Branch
Firefox 2
verified1.8.1.1
Points:
---
Bug Flags:
blocking1.8.1.1 +

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Assignee)

Description

12 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.8.1) Gecko/20061010 Firefox/2.0
Build Identifier: N/A

The value of 'browser.search.selectedEngine' pref should be saved as complex value.
I'll make a patch.


Reproducible: Always

Steps to Reproduce:
1. Select new search engine with non-ascii characters from search bar.
2. Restart Firefox.

Actual Results:  
Selected search engine is now the default engine of Firefox.

Expected Results:  
Selected search engine is the engine i chose.
Status: UNCONFIRMED → NEW
Ever confirmed: true
(Assignee)

Comment 1

12 years ago
Created attachment 244198 [details] [diff] [review]
patch v1

This works for me.
(Assignee)

Comment 2

12 years ago
We at Mozilla Japan request this fix for blocking1.8.1.1.
Flags: blocking1.8.1.1?
Assignee: nobody → kohei.yoshino.bugs
Target Milestone: --- → Firefox 2
Version: unspecified → 2.0 Branch
(Assignee)

Comment 3

12 years ago
Created attachment 244201 [details]
search engine with non-ascii characters

The search plugin of 楽天市場 (Rakuten shopping mall) that comes with ja locale.
You can test with it.
Thanks for the patch, and for finding my mistake :(. I landed this fix on the trunk, please verify.

mozilla/browser/components/search/nsSearchService.js 	1.88
Status: NEW → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → FIXED
Attachment #244198 - Flags: approval1.8.1.1?
(Assignee)

Comment 5

12 years ago
Looks good on the trunk. Thank you!
Status: RESOLVED → VERIFIED

Updated

12 years ago
Flags: blocking1.8.1.1? → blocking1.8.1.1+

Comment 6

12 years ago
Comment on attachment 244198 [details] [diff] [review]
patch v1

Approved for 1.8.1 branch, a=jay for drivers.  Please land asap.  Thanks!
Attachment #244198 - Flags: approval1.8.1.1? → approval1.8.1.1+
mozilla/browser/components/search/nsSearchService.js 	1.1.2.72
Keywords: fixed1.8.1.1

Comment 8

12 years ago
Kohei:  Could you please verify this on the 1.8 branch as well?  Please test with  the latest -mozilla1.8 build and replace "fixed1.8.1.1" with "verified1.8.1.1" if the search engine selection works as expected.  Thanks!
(Assignee)

Comment 9

12 years ago
Verified. Thanks!
Keywords: fixed1.8.1.1 → verified1.8.1.1
You need to log in before you can comment on or make changes to this bug.