The default bug view has changed. See this FAQ.

crash [@ EmbedPrivate::Realize]

RESOLVED FIXED

Status

Core Graveyard
Embedding: GTK Widget
--
critical
RESOLVED FIXED
11 years ago
5 years ago

People

(Reporter: Chris Lahey, Assigned: timeless)

Tracking

({crash})

Trunk
x86
Linux
crash

Firefox Tracking Flags

(Not tracked)

Details

(crash signature)

Attachments

(1 attachment)

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.0.2) Gecko/20060419 Fedora/1.5.0.2-1.2.fc5 Firefox/1.5.0.2 pango-text
Build Identifier: firefox package as shipped with Fedora Core 6

I've looked into it and mWindow->Init(this) is returning NS_ERROR_FAILURE, which is being ignored.  mWindow->Init(this) is failing because do_CreateInstance(NS_WEBBROWSER_CONTRACTID); is returning a null pointer.  It looks as if this is because NS_WEBBROWSER_CONTRACTID ("@mozilla.org/embedding/browser/nsWebBrowser;1") isn't in the component registry.  Is there some change to the way I need to initialize gtkmozembed?

Reproducible: Always

Steps to Reproduce:
1. Install FC6
2. Download and run democracyplayer as described at https://develop.participatoryculture.org/projects/democracy/wiki/GTKX11BuildDocs
Actual Results:  
App crashes.  After debugging, have traced problem to do_CreateInstance.

Comment 1

11 years ago
Maybe you should report this to the democracy guys, too?
Keywords: crash
Summary: EmbedPrivate::Realize crashes → crash [@ EmbedPrivate::Realize]
(Reporter)

Comment 2

11 years ago
I am one of the democracy guys.  I'm trying to figure out how to change democracy to fix it.

Comment 3

11 years ago
Looks like this is the same bug as reported here:

https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=205499
(Reporter)

Comment 4

11 years ago
It is the same thing, I think.  It's explored further here, I think.

I've explored it some more.  On FC6, we fixed it by calling set_comp_path.  However, with newer gtks like on ubuntu or gentoo, a very similar crash occurs unless you set LD_LIBRARY_PATH to the mozilla path.
(Assignee)

Comment 5

11 years ago
i'll gladly r+ the patch to add the null check, please post it, or wait for me to do all the other work i have to do to catch up.

but the null check won't solve your problem. gecko embedding requirements include someone telling gecko where to find the libraries they want used. classically this is handled by run-mozilla.sh.
What are you trying to embed, and what linkage strategy are you using?
(Assignee)

Comment 7

11 years ago
Created attachment 246659 [details] [diff] [review]
look before leaping
Assignee: nobody → timeless
Status: UNCONFIRMED → ASSIGNED
Attachment #246659 - Flags: review?(cbiesinger)
(Assignee)

Comment 8

10 years ago
Comment on attachment 246659 [details] [diff] [review]
look before leaping

this is nuts. I'm something of a module owner, and even I can't get reviews.

I'm not going to try again.
Attachment #246659 - Flags: superreview?(bzbarsky)
Attachment #246659 - Flags: review?(cbiesinger) → review+
Comment on attachment 246659 [details] [diff] [review]
look before leaping

Sure.
Attachment #246659 - Flags: superreview?(bzbarsky) → superreview+
(Assignee)

Updated

10 years ago
Attachment #246659 - Flags: approval1.9?
Comment on attachment 246659 [details] [diff] [review]
look before leaping

a=bzbarsky
Attachment #246659 - Flags: approval1.9? → approval1.9+
(Assignee)

Comment 11

10 years ago
mozilla/embedding/browser/gtk/src/EmbedPrivate.cpp 	1.65 <timeless@mozdev.org> 2006-12-03 20:06

joke's on me. sorry all.
Status: ASSIGNED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → FIXED
Crash Signature: [@ EmbedPrivate::Realize]
Component: Embedding: GTK Widget → Embedding: GTK Widget
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.