Spellchecker suggestions/actions not always included in context menu

VERIFIED DUPLICATE of bug 346930

Status

()

Firefox
General
VERIFIED DUPLICATE of bug 346930
12 years ago
10 years ago

People

(Reporter: Jared, Unassigned)

Tracking

2.0 Branch
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1) Gecko/20061010 Firefox/2.0
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1) Gecko/20061010 Firefox/2.0

When right-clicking on a misspelled word, the context menu includes a list of suggested spellings (if available), followed by an option to add the word to the user's dictionary.  This works fine if the context menu is invoked by right-clicking on the word with the mouse, but it is also possible to display the context menu with the keyboard.  This can be done by pressing Shift-F10, or by pressing the menu key on keyboards with "Windows keys".  If the context menu is brought up using one of the keyboard methods while the cursor is on a misspelled word, the the spellchecker suggestions are not displayed, nor is the "Add to dictionary" option.

Reproducible: Always

Steps to Reproduce:
1. Type some text in a textarea field and intentionally misspell a word.
2. Move the cursor to the misspelled word
3. Hit Shift-F10 or the menu key on your keyboard and notice that the spellcheck options are not present
4. Hit escape to close the menu, then right-click on the word to see the expected spellcheck options

Actual Results:  
Spellcecker options are not displayed for misspelled words when the context menu is invoked via the keyboard.

Expected Results:  
Spellchecker options should always be displayed in the context menu when spellchecking is enabled, regardless of the input method used to display the menu.

I've only tested this under Windows XP.  I'm not sure if this is an issue on other platforms.

Comment 1

12 years ago

*** This bug has been marked as a duplicate of 346930 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → DUPLICATE
V.Duplicate
Status: RESOLVED → VERIFIED
Version: unspecified → 2.0 Branch
You need to log in before you can comment on or make changes to this bug.