configure failed to set ac_cv_visibility_pragma=no causing compile error

RESOLVED DUPLICATE of bug 353150

Status

RESOLVED DUPLICATE of bug 353150
12 years ago
10 months ago

People

(Reporter: mats, Unassigned)

Tracking

Trunk
x86
Linux

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

12 years ago
configure failed to set ac_cv_visibility_pragma=no causing compile error (bug
356806).  I'm guessing from bug 334866 that configure should have detected
this gcc error and avoided it by setting ac_cv_visibility_pragma=no.

My platform is:
Kubuntu 6.10 with default compiler that is:
# gcc -v
Using built-in specs.
Target: x86_64-linux-gnu
Configured with: ../src/configure -v --enable-languages=c,c++,fortran,objc,obj-c++,treelang --prefix=/usr --enable-shared --with-system-zlib --libexecdir=/usr/lib --without-included-gettext --enable-threads=posix --enable-nls --program-suffix=-4.1 --enable-__cxa_atexit --enable-clocale=gnu --enable-libstdcxx-debug --enable-mpfr --enable-checking=release x86_64-linux-gnu
Thread model: posix
gcc version 4.1.2 20060928 (prerelease) (Ubuntu 4.1.1-13ubuntu5)

Comment 1

12 years ago
duplicate of bug 353150?
which branch did you use?
(Reporter)

Comment 3

12 years ago
(In reply to comment #1)
> duplicate of bug 353150?

Possibly, I got a different compile error, bug 356806 comment 0 to be precise.
I'll try the patch in bug 353150 and see if it helps...

(In reply to comment #2)
> which branch did you use?

trunk

(Reporter)

Comment 4

12 years ago
Yes, the patch in bug 353150 fixed it. Thanks.

An observation: the compilation (.c[pp]->.o) is faster on this (new) box but
linking the dynamic libraries are an order of magnitude slower, especially
the larger ones like libgklayout.so. I wonder if this symbol visibility thing
has something to do with it...
New box: 2.67GHz Core 2 Duo, Linux 2.6/x86_64, gcc 4.1.2
Old box: 3.0GHz P4, Linux 2.4/i386, gcc 3.3.1

*** This bug has been marked as a duplicate of 353150 ***
Status: NEW → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → DUPLICATE

Updated

10 months ago
Product: Core → Firefox Build System
You need to log in before you can comment on or make changes to this bug.