"do this automatically" fails for application/x-nzb with Transfer-Encoding: chunked and content-disposition: attachment;

RESOLVED DUPLICATE of bug 285976

Status

()

defect
RESOLVED DUPLICATE of bug 285976
13 years ago
11 years ago

People

(Reporter: mardeg, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

()

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1) Gecko/20061010 Firefox/2.0
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1) Gecko/20061010 Firefox/2.0

Discovered by a visitor to the #firefox channel.

I was expecting this to be another server-side configuration error to do with not enclosing the filename in quotes on the content-disposition line in the http headers, however the filename is enclosed in quotes and I'm wondering what the reason is for Firefox not remembering how to open this file when the correct mime type for it is also set.
Is it due to some arbitrary content sniffing that notices the file is in binary format and overrides the chosen setting? If this is the desired behaviour, correct or otherwise, then please resolve this bug as invalid.

Reproducible: Always

Steps to Reproduce:
1. Install software that can open .nzb files, do a search and pick a file by ticking the box
2. Click on "Create NZB", then in the "what should Firefox do with this file?" dialog choose to open it with the installed program and tick "do this automatically"
3. Repeat 1. and 2. till you decide to report it in #firefox

Actual Results:  
"what should Firefox do with this file?" keeps appearing

Expected Results:  
Open with the selected program automatically

No obvious workaround was found.

*** This bug has been marked as a duplicate of 285976 ***
Status: UNCONFIRMED → RESOLVED
Closed: 13 years ago
Resolution: --- → DUPLICATE
Product: Firefox → Toolkit
You need to log in before you can comment on or make changes to this bug.