bugzilla.mozilla.org has resumed normal operation. Attachments prior to 2014 will be unavailable for a few days. This is tracked in Bug 1475801.
Please report any other irregularities here.

Can't use keyboard to navigate in pages

VERIFIED WORKSFORME

Status

()

Core
Keyboard: Navigation
P3
normal
VERIFIED WORKSFORME
20 years ago
18 years ago

People

(Reporter: cpratt, Assigned: Chris McAfee)

Tracking

Trunk
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [nsbeta2-] [nsbeta3+][PDTP3])

Attachments

(1 attachment)

(Reporter)

Description

20 years ago
You can't use the keyboard to tab between links on a page, or follow a link on
the page by pressing Enter. This is preventing us from testing things such as
the TABORDER attribute.

Sample HTML to see this:

<a href="http://www.mozilla.org" tabindex="1">mozilla.org<a>
<a href="http://www.netscape.com" tabindex="2">Netscape<a>
<a href="http://www.websitegarage.com" tabindex="3">Web Site Garage<a>
<a href="http://www.aol.com" tabindex="4">America Online<a>

Updated

20 years ago
Assignee: shuang → german

Updated

20 years ago
Assignee: german → don

Comment 1

20 years ago
Agreed. I am not sure though who is implementing this (raptor side or XPFE side)
or when this will be implemented, so I am forwarding to Don coz he'll know :-)

Updated

20 years ago
Target Milestone: M7
(Reporter)

Updated

20 years ago
QA Contact: 4137
Target Milestone: M7

Comment 2

20 years ago
Set target milestone to M7.

Updated

20 years ago
Target Milestone: M7

Updated

19 years ago
Target Milestone: M7 → M11

Comment 3

19 years ago
We won't get to this until M11 ...

Updated

19 years ago
Blocks: 2634

Updated

19 years ago
Blocks: 16271

Comment 4

19 years ago
Adding Bug 16271 (Tab order of Form Controls in FORM) to dependency list;
it can't be properly tested until this is fixed for certain.

Updated

19 years ago
No longer blocks: 16271

Updated

19 years ago
Assignee: don → mcafee
Priority: P3 → P2
Target Milestone: M11 → M13

Comment 5

19 years ago
It looks like TABINDEX support has received some attention lately but isn't
finished yet: the testcase in bug 2642 allows TABINDEX navigation, but
messes up the ordering the second and subsequent times through the sequence.

Also, testing that bug was impossible without first giving focus to the
page explicitly by clicking anywhere on the canvas. For those who actually
*need* to be able to tab between page elements to use the browser without a
mouse, this isn't good enough.

This looks to be another symptom of a bug that is more general than first
noted: in bug 12280, keyboard scrolling does not work until focus is given with
a click. This should get fixed before bug 3593 is called fixed.

Comment 6

19 years ago
Navigator 4.7 seems to deal with the problem of getting focus onto the page
without using the mouse by including the Location Bar in the tabbing sequence,
before anything else.

This could also work in Mozilla - but it would still be better to give the
page itself focus for keyboard events once it starts loading, for the reasons
given in bug 12280.
(Assignee)

Updated

19 years ago
Depends on: 2674

Updated

19 years ago
Target Milestone: M13 → M15

Comment 7

19 years ago
This is one part of keyboard navigation that won't make it into beta 1.

Comment 8

19 years ago
Moving all UE/UI bugs to new component: User Interface: Design Feedback
UE/UI component will be deleted.
Component: UE/UI → User Interface: Design Feedback

Comment 9

19 years ago
Move to M16 for now ...
Target Milestone: M15 → M16

Updated

19 years ago
Keywords: nsbeta2
Whiteboard: [FEATURE]
Target Milestone: M16 → M17

Comment 10

18 years ago
Putting on [nsbeta2+][5/16] radar.  This is a feature MUST complete work by 
05/16 or we may pull this feature for PR2.
Whiteboard: [FEATURE] → [nsbeta2+][5/16][FEATURE]

Comment 11

18 years ago
Move to M19 target milestone.
Target Milestone: M17 → M19

Comment 12

18 years ago
Putting on [nsbeta2-] radar.  Removing [5/16] and [FEATURE].  would take for 
nsbeta3.
Keywords: nsbeta3
Whiteboard: [nsbeta2+][5/16][FEATURE] → [nsbeta2-]

Comment 13

18 years ago
Nav triage team: [nsbeta3+]
Whiteboard: [nsbeta2-] → [nsbeta2-] [nsbeta3+]

Comment 14

18 years ago
It's also impossible to navigate using the keyboard in linux, and one would
assume, everything else.  Shouldn't the bug specify more than just NT?
OS: Windows NT → All
Hardware: PC → All
(Assignee)

Updated

18 years ago
Priority: P2 → P1

Comment 15

18 years ago
Chris,  we've decided to give keyboard navigation bugs lower priority.  Please 
adjust to P2 (or lower) at your discretion.
(Reporter)

Comment 16

18 years ago
Don't do it, Chris! I'm begging you! This makes Mozilla completely unusable for 
a fair number of users, myself included.

Comment 17

18 years ago
law was too nice.  We demoted this during nav triage to P2, marking P2 now.  
Agreed that this sucks royally, but it sucks even more that in the last week our 
total P1 count for Don's team has grown (we are supposed to be down to 33, but 
are actually up to 53).  At that rate, we will not ship - for anyone.

Also adding keyword helpwanted because keyboard shortcuts is the #1 helpwanted 
request the Nav team has for mozilla.org.

If we want to get this fix in, we need mozilla help or need to finish higher 
priority bugs first.

Signed,
The evil voice of reality
Priority: P1 → P2
(Assignee)

Comment 18

18 years ago
Created attachment 14232 [details]
test file
(Assignee)

Comment 19

18 years ago
This is working on linux, renders rectangles around links and
return visits the link.  Win32 & Mac, no rectangle renders and
return does nothing.
Component: User Interface: Design Feedback → Keyboard Navigation
(Assignee)

Comment 20

18 years ago
adding joki.

Comment 21

18 years ago
PDT thinks this is a P3, but it worksforme using today's Win32 build
Priority: P2 → P3
Whiteboard: [nsbeta2-] [nsbeta3+] → [nsbeta2-] [nsbeta3+][PDTP3]
(Assignee)

Comment 22

18 years ago
Ah, urlbar is stealing focus.  Looks like this is WFM.
Click in the main body of the content to get focus,
then this is working.
Status: NEW → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → WORKSFORME
(Reporter)

Updated

18 years ago
QA Contact: cpratt → claudius

Comment 23

18 years ago
reassigning QA w/o even looking...
QA Contact: claudius → sairuh

Comment 24

18 years ago
Verified
Status: RESOLVED → VERIFIED
well, i cannot tab btwn links when the page has tables...eg,
http://www.mozilla.org. will file a seperate bug for that (not sure if tables
per se are the cause, tho'...)
You need to log in before you can comment on or make changes to this bug.