In both the prefs and the download window toolbar we use the word "downloads" to mean entries in the download manager list, and "files" or "downloaded files" to mean the actual files. This is a pretty sketchy distinction; I can't imagine anyone being confronted with the term "downloads" and not thinking it means things they download. "Remove successful downloads upon completion" just doesn't make any sense as worded, and the remove/trash distinction is a bit fuzzy. We really need to try to come up with better language (and maybe ways of simplifying the downloads toolbar).
The tooltip for Remove is really easy to fix, and that would probably make a big difference there: "Remove selected item(s) from the list" or something (and likewise for "Clean up"). Trash I think is pretty clear (although it was originally supposed to be labeled "Move to Trash" but was shorted at the last minute for space reasons (bug 329011). For the prefs, it's much more difficult, as the two non-manual actions only remove successfully-completed downloads (not cancelled/failed ones, so that we can manually restart--and future resume--etc.) That's why the text is "successful downloads" and not whatever Safari uses; we went through several revisions earlier this year to get this right. See bug 341701 comment 0, 1 and 4.
The context menu's "Remove" option should probably be re-worded too. It may be less confusing (a little) due to its proximity to "Move to Trash" but it's still kinda inconsistent. cl
Ian says we need to at least fix the tooltips (toss in "list" somewhere).
As an immediate fix, I think we should use "downloads" to refer to items currently being downloaded, "items" to refer to list management, and "files" to refer to the result of a finished download. - "dlRemoveButtonTooltip" = Remove selected download(s); + "dlRemoveButtonTooltip" = Remove selected items(s) from the list; - "dlRevealButtonTooltip" = "Show selected downloads(s) in Finder"; + "dlRevealButtonTooltip" = "Show selected files(s) in Finder"; - "dlCleanUpButtonTooltip" = "Remove all inactive downloads(s)"; + "dlCleanUpButtonTooltip" = "Remove all inactive items(s) from the list"; However, I agree that rewording the prefs is something we should keep in mind - we might consider leaving this bug open after these string changes and targeting the remaining work for a later day.
r/sr=me on those changes, but also change "Open saved file(s)" to "Open selected file(s)" to be consistent with everything else. We do need to keep this open for the prefs though.
String changes checked in. Clearing 1.1b1? flag instead of plussing, since the remainder of this bug isn't for 1.1.
Mass un-setting milestone per 1.6 roadmap. Filter on RemoveRedonkulousBuglist to remove bugspam. Developers: if you have a patch in hand for one of these bugs, you may pull the bug back to 1.6 *at that point*.