Middle-click on javascript link opens new empty tab

RESOLVED DUPLICATE of bug 55696

Status

()

Firefox
Tabbed Browser
RESOLVED DUPLICATE of bug 55696
12 years ago
12 years ago

People

(Reporter: uli.2001, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; de; rv:1.8.0.7) Gecko/20060911 SUSE/1.5.0.7-1.5 Firefox/1.5.0.7
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; de; rv:1.8.0.7) Gecko/20060911 SUSE/1.5.0.7-1.5 Firefox/1.5.0.7

Clicking on a url with the middle mouse button usually opens the target in a new tab. However, this does not work with links pointing to some javascript code.

The link address is something like javascript:FensterP3235()

Reproducible: Always

Steps to Reproduce:
1. go to http://www.digitalkamera.de/Belichtung/ 
2. using the middle mouse button, click on one of the links pointing to something like "javascript:FensterP3235()" in the right-most column of the big table

Actual Results:  
a new empty tab with "javascript:FensterP3235()" in the address bar is opened

Expected Results:  
Since the javascript code mainly opens a new window in this case, the window should be opened and sent to the new tab.
Or middle-clicking should just do the same as left-clicking.
Or middle-clicking should do nothing at all.


Firefox seems to know that it cannot open a javascript link in a new tab: right-clicking on the link does not offer "open link in new tab" in the context menu.

Comment 1

12 years ago

*** This bug has been marked as a duplicate of 55696 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.