highlighting url text and replacing it with new text and then <CR> results in a crash

VERIFIED DUPLICATE of bug 35954

Status

()

Core
Editor
P3
critical
VERIFIED DUPLICATE of bug 35954
18 years ago
17 years ago

People

(Reporter: fstmm, Assigned: rubydoo123)

Tracking

Trunk
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

18 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux 2.2.12-20 i686; en-US; m14) Gecko/20000415
BuildID:    2000041508

Starting at any page, say http://mozilla.org, highlighting the text - say
mozilla.org, replacing it with a new address - say slashdot.org, and pressing
return, results in a browser crash.

Reproducible: Always
Steps to Reproduce:
1.highlight url address
2.type in destination address
3.press return

Actual Results:  browser crash, the terminal windows says >>>>>>>>>> Write
Clipboard to memory upon highlighting

Expected Results:  just gone to the url entered

Comment 1

18 years ago
Confirmed on Win32 2000041508 on NT. I can reproduce the crash by simply 
single-clicking in the URL bar - it doesn't even begin to highlight.
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 2

18 years ago
duplicate of bug 35954

Comment 3

18 years ago
Marking dup.

khecht19, I suspect that what you're seeing is a different bug.  This regressed
recently, and the stacktrace in bug 35954 indicates that it's in the unix
clipboard code.  Pavlov and Pinkerton checked in major changes to that code in
the last 2 days.  Suggest you file a new bug.

*** This bug has been marked as a duplicate of 35954 ***
Status: NEW → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → DUPLICATE

Comment 4

18 years ago
verified in 4/17 build.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.