Periodic events with start date < 1970 are not displayed. SunBird crashes when event is selected.

VERIFIED DUPLICATE of bug 324293

Status

Calendar
Calendar Views
--
critical
VERIFIED DUPLICATE of bug 324293
11 years ago
11 years ago

People

(Reporter: Jean-Dominique Delyon, Unassigned)

Tracking

Details

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; fr; rv:1.8.1) Gecko/20061010 Firefox/2.0
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; fr; rv:1.8.1) Gecko/20061010 Firefox/2.0

I publish a .ics on a remote server, the calendar being initially built with Lightning.
In this agenda are located the anniversaries, which are recorded "Birth date", "Whole day", "Alarm 1 day before", "Yearly".
When I have a look on the .ics file, it seems OK.
When I open the remote agenda from SunBird (0.3a1 FR), the event is not displayed on the calendar (month) view. But I can see it on the events list.
If I click on the event in the list, SunBird crashes.

Reproducible: Always

Steps to Reproduce:
1. I create an event whith Lightning as follow:
Title: "Anniversaire Annie Aubry"
Location: <Empty>
From: January 2nd, 1939.
To: Idem.
Whole day, Repeat Yearly.
Alarm is 1 day before.
Agenda is local.
2. I publish the calendar on icalx.com, private storage. The result seems OK.
BEGIN:VCALENDAR
VERSION:2.0
PRODID:-//Mozilla.org/NONSGML Mozilla Calendar V1.1//EN
BEGIN:VEVENT
CREATED:20061106T205345Z
LAST-MODIFIED:20061106T205346Z
DTSTAMP:20061106T205346Z
UID:uuid1162653553856
SUMMARY:Anniversaire Annie Aubry
PRIORITY:9
STATUS:CONFIRMED
CLASS:PUBLIC
RRULE:FREQ=YEARLY;INTERVAL=1
DTSTART;VALUE=DATE;TZID=/mozilla.org/20050126_1/Europe/Paris:19390102
DTEND;VALUE=DATE;TZID=/mozilla.org/20050126_1/Europe/Paris:19390103
BEGIN:VALARM
TRIGGER;VALUE=DURATION:-P1D
DESCRIPTION:Mozilla Alarm: Anniversaire Annie Aubry
ACTION:DISPLAY
END:VALARM
END:VEVENT
3. I create a new remote agenda in SunBird, aiming on this .ics file.

Actual Results:  
In sunbird, only events starting AFTER 1970/01/01 are displayed on the calendar view.
The events before are only displayed in the events/tasks list, and sunbird crashes when the event is selected.

Expected Results:  
Sunbird should display these events correctly and should not crash.

The calendar is correctly displayed by icalx.com in html mode (PHPiCalendar).

Comment 1

11 years ago
This is already fixed in Sunbird 0.3 release. I recommend to update to the latest version [http://www.mozilla.org/projects/calendar/releases/sunbird0.3.html]

*** This bug has been marked as a duplicate of 324293 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → DUPLICATE

Updated

11 years ago
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.