No option to "Open" a .SAP file type that is registered with Win XP.

RESOLVED DUPLICATE of bug 359948

Status

()

Firefox
File Handling
RESOLVED DUPLICATE of bug 359948
11 years ago
11 years ago

People

(Reporter: Stephen Prather, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1) Gecko/20061010 Firefox/2.0
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1) Gecko/20061010 Firefox/2.0

This worked ok in 1.5. Does not work in 2.0.

When I click a link in MS Outlook that initiates a download of a .SAP file, Firefox only asks if I want to Save the file. There is no option to Open it. Not only do I want to Open it, I want to tell Firefox to never ask me but always Open it. The .SAP file is registered with Windows. After saving the file, I am able to open it using the Download Manager. The .SAP file should be stored in temporary DL space, not in my usual DL directory (my Desktop). In other words, I don't want these little .SAP files cluttering my Desktop like they do now.

Also, why is there no way to add an action for a filetype in the manage filetypes interface?

Tools->Options...->Content->FileTypes->Manage

A web search shows that I'm not the only person wondering why this is missing.

Anyway, thanks for Firefox2. It's really great. Needs polish though.

Thanks!
--Myles

Reproducible: Always

Steps to Reproduce:
1. Initiate the DL of a .SAP file from Outlook.
2.
3.

Actual Results:  
Firefox asks me if I want to save the file.

Expected Results:  
I should have the option to a) Open the file, and b) specify that Firefox always Open files of this type.

I can take screen grabs showing the bogus operations. I'm just not sure where to put them.
(Reporter)

Comment 1

11 years ago
Created attachment 244835 [details]
This image shows that Windows knows what to do with this filetype.
(Reporter)

Comment 2

11 years ago
Created attachment 244836 [details]
There is no option to Open this filetype
Do you mean Outlook Web access ?
And are you sure that the Web Server doesn't send an attachment header ?
(Reporter)

Comment 4

11 years ago
Hi Matti--

I am initiating the action from my local Outlook client. Not web based. The link in the email I get looks like this:


To view the details of the STAR in Win GUI screen Click on this URL:
  http://<host-url-deleted-by-me>/~batchmgr/crm/create_shortcut.cgi?object_id=9000144862&guid=45370BAC7E326310E100000092E15023&sys=CRM


I'm not sure whether or not there's an attachment header since I don't know what that is. Well, I sorta do, but I don't how how to determine the answer to your question.

The contents of the file, once saved on my desktop, is just text fields used by sapgui to figure out what it needs to do.

Is there any way to save the raw stream of data sent by the web server that responds to the URL above? As you can tell, I'm speaking mostly gibberish. I'll just fumble around and let you lead me to answers you seek.

But remember, it worked ok'ish in 1.5. Stopped working in 2.0. The problem I had in 1.5 (and 2.0) is that it leaves an empty tab opened in Firefox even when I use an extension created to prevent that from happening. For some reason, the extension would not work even when I told it not to open the empty tab for .sap files. Maybe this is a clue?

Thanks Matti!
--Myles
I bet that Outlook sends an attachment header in this case.
In Seamonkey you can open this with an application but you can't save the decision (and you will always get the download dialog with an attachemtn header).

It seems that the Firefox UI doesn't have an "open with" for Files with attachment header and/or if FF does content sniffing.

Duping to bug 


*** This bug has been marked as a duplicate of 359948 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.