bugzilla.mozilla.org has resumed normal operation. Attachments prior to 2014 will be unavailable for a few days. This is tracked in Bug 1475801.
Please report any other irregularities here.

Status

()

Core
Networking
P3
normal
VERIFIED DUPLICATE of bug 11459
19 years ago
17 years ago

People

(Reporter: Jeremiah Rogers, Assigned: asa)

Tracking

Trunk
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

19 years ago
When I put a link for email on my website, and tried to access it with a
compiliation of mozilla that didn't have mail/news built in, I got an error that
said there was no mailto protocol.

Comment 1

19 years ago
I'm curious about that.  I mean, shouldn't we expect the mailto: *not* to work
*because* there is no mail/news element installed? Without the mail/news
component installed, mozilla probably wouldn't know how to handle the mailto:
request.

Comment 2

19 years ago
jeremiah, what do you think is a bug about the behavior that you describe?
(Reporter)

Comment 3

19 years ago
Yes, i would expect that mailto: should not work when there is no mail/news
element installed. However I think it should be concidered a bug for mozilla to
complain about mailto: not being a protocol. While clicking on the mailto: link
shouldn't work, mozilla probably shouldn't have a problem with the link if there
is no mail/news element, just as netscape standalone doesn't complain about
mailto: links, but still doesn't let me send mail through them.

Comment 4

19 years ago
I'm not going to compile Mozilla without Mailnews to verify this, but I suspect
that the error message says "mailto: is not a *registered* protocol"  (emphasis
mine).  And if you don't have Mailnews installed, that's exactly true.  There is
no mailto: protocol handler, so mailto: is not a registered protocol.  I still
don't see a bug here.

Comment 5

19 years ago
Seems to me that mozilla's just telling you something straight out.  There's no 
mailto: protocol because there's nothing to handle it, if you haven't installed 
the mail/news element.  In that situation, perhaps mozilla could "reference" to 
the user's OS, asking what's the default mail reader so if you didn't install 
mozilla's mail/news, it'd automatically go somewhere else (eg. Eudora)?

Comment 6

19 years ago
Bug 11459 covers being able to use external mail clients or webmail for mailto:
URLs.
(Assignee)

Comment 7

18 years ago
I think that this is a wontfix or a duplicate of 11459.  marking it duplicate.  

*** This bug has been marked as a duplicate of 11459 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → DUPLICATE
(Assignee)

Comment 8

18 years ago
Sorry for the spam.  New QA Contact for Browser General.  Thanks for your help
Joseph (good luck with the new job) and welcome aboard Doron Rosenberg
QA Contact: jelwell → doronr

Comment 9

18 years ago
verify
Status: RESOLVED → VERIFIED

Comment 10

17 years ago
->networking
QA reviewed.
Testcases and documentation done.
Component: Browser-General → Networking
You need to log in before you can comment on or make changes to this bug.