Closed Bug 359878 Opened 15 years ago Closed 15 years ago

Session restore is painful if session to be restored contains password-protected pages and you have a master password set

Categories

(Toolkit :: Startup and Profile System, defect)

1.8 Branch
PowerPC
macOS
defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 348997

People

(Reporter: justdave, Unassigned)

Details

Conditions to reproduce:
1. Have a few pages open that require passwords to access.  https://nagios.mozilla.org/ is a good one (log in as guest/guest).
2. Have a master password set in your preferences.
3. Have Firefox crash (or send it a SIGSEGV to force it)
4. Launch Firefox again

Actual results:
1. Master Password prompt appears.
2. Master Password prompt appears again, right overtop of the one you were already typing in, after you've only typed 3 or 4 characters in it
3. Other pages that didn't require passwords open overtop of the password dialogs
4. The password protected page(s) show up in the Window menu, but choosing them doesn't bring them to the front.
5. Choosing the _blank_ entries from the Window menu bring a Master Password dialog back to the front.
6. Entering the password and clicking OK causes *all* of the password protected pages to now become visible, but leaves one of the password dialogs still open.
7. You can now pick the other black entry from the Window menu to get the other password dialog back, and just hit cancel (because it's already been entered).

Expected results:
1. Only prompt once for Master Password
2. Keep the Master Password dialog in front until the password has been entered (or open all other new windows behind it -- or wait for the password before opening *any* windows?)

*** This bug has been marked as a duplicate of 348997 ***
Status: NEW → RESOLVED
Closed: 15 years ago
Resolution: --- → DUPLICATE
Product: Firefox → Toolkit
You need to log in before you can comment on or make changes to this bug.