autoconfig e-mail address detection doesn't work with multiple identities

RESOLVED FIXED

Status

()

Core
Preferences: Backend
RESOLVED FIXED
11 years ago
11 years ago

People

(Reporter: Bienvenu, Assigned: Bienvenu)

Tracking

({fixed1.8.1.1})

Trunk
x86
Windows XP
fixed1.8.1.1
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments, 1 obsolete attachment)

(Assignee)

Description

11 years ago
If the default account has multiple identities, we can't find the e-mail address from the identity, because we don't parse the multiple identities. Patch upcoming
(Assignee)

Comment 1

11 years ago
Created attachment 244943 [details] [diff] [review]
proposed fix
Attachment #244943 - Flags: superreview?(mscott)

Updated

11 years ago
Attachment #244943 - Flags: superreview?(mscott) → superreview+
(Assignee)

Comment 2

11 years ago
Created attachment 246807 [details] [diff] [review]
fix as checked in

there was a bug in the previous patch - we need to adjust the length of the id string as well - this is what I'll land. Carrying forward sr.
Attachment #244943 - Attachment is obsolete: true
Attachment #246807 - Flags: superreview+
(Assignee)

Comment 3

11 years ago
Created attachment 246812 [details] [diff] [review]
patch for trunk/2.0 branch

this is a patch for the trunk/2.0 branch - prev patch was for 1.0 branch
(Assignee)

Comment 4

11 years ago
fixed on trunk and branches.
Status: NEW → RESOLVED
Last Resolved: 11 years ago
Keywords: fixed1.8.1.1
Resolution: --- → FIXED
(Assignee)

Comment 5

11 years ago
for QA/testing, this change only affects autoconfig, and testing autoconfig is a bit of a challenge. But see this for some info:

http://developer.mozilla.org/en/docs/MCD%2C_Mission_Control_Desktop_AKA_AutoConfig
You need to log in before you can comment on or make changes to this bug.