status bar does not show the degre symbol "°" from applet java

RESOLVED INVALID

Status

()

Core
Plug-ins
P5
normal
RESOLVED INVALID
11 years ago
5 years ago

People

(Reporter: armand bendanan, Unassigned)

Tracking

(Depends on: 1 bug)

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(3 attachments)

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; fr-FR; rv:1.8.1) Gecko/20061010 Firefox/2.0
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; fr-FR; rv:1.8.1) Gecko/20061010 Firefox/2.0

If I try to print a string containing a ° character in the status bar
using the showStatus() method from Applet, the degre character and all
the remaining string is not printed.

Reproducible: Always

Steps to Reproduce:
1.launch the applet with the HTML file
2.clic on the button "show status"
3.

Actual Results:  
the status bar print:
Position : N49

Expected Results:  
the status bar should print:
Position : N49° 28' 32''
(Reporter)

Comment 1

11 years ago
Created attachment 244947 [details]
The HTML file which contains the applet
(Reporter)

Comment 2

11 years ago
Created attachment 244948 [details]
The applet that demonstrate the bug
(Reporter)

Updated

11 years ago
Attachment #244947 - Attachment mime type: text/html → text/plain
(Reporter)

Comment 3

11 years ago
Note : the problem does not occurs with I.E.
Reporter, do you still see this problem with the latest Firefox 2 and the latest Java? If not, can you please close this bug as WORKSFORME. Thanks!
Whiteboard: CLOSEME 07/14
Version: unspecified → 2.0 Branch
(Reporter)

Comment 5

11 years ago
Steve,
I am using the 2.0.0.4 version of firefox and the JRE 1.6.0_01 Java HotSpot(TM) Client VM version for java and the bug is still here.

The applet source code contains only 18 lines (with the import lines). Ir is WERY easy to compile and test it.

Did you try my little applet ?
Have you a version of Firefox or Java which works fine for this bug ?

Thanks
Due to lack of reporter feedback and the inability to reproduce this bug, it is
being resolved as INCOMPLETE.  Reporter, feel free to reopen this bug if you
still are experiencing this issue and wish to provide us with more information
so that we can help.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → INCOMPLETE
(Reporter)

Comment 7

10 years ago
Anthony,

Did you try to compile the little applet and launched it with the HTML page that are attached?

There is no other feedback that I can add.

Which kind of feedback do you need?
Your applet does not work using FF 2.0.0.6 and Java 6 update 2.  It generates an error: "Incompatible magic value 1768779887 in class file BugShowStatus"
(Reporter)

Comment 9

10 years ago
Anthony,

You are not serious at all.

I have FF 2.0.0.6 and Java 6 update 2.

I tested the applet and FF nor JAVA does NOT display any error like you state.

I will attache an hard copy of the FF window with the status bar which display:
Position : N49
insteed of:
Position : N49° 28' 32''

Many thanks for your precious and very valuable help.
Armand Bendanan.
Status: RESOLVED → UNCONFIRMED
Resolution: INCOMPLETE → ---
(Reporter)

Comment 10

10 years ago
Created attachment 279558 [details]
The hard copy with FF 2.0.0.6 which display a wrong status bar

Updated

10 years ago
Component: General → Plug-ins
Product: Firefox → Core
QA Contact: general → plugins
Version: 2.0 Branch → unspecified
I cannot get your applet to run at all and when I check the Java Console, I see the error I specified before.  Perhaps someone else in the community with more expertise in JS would like to jump in here and help out.
Whiteboard: CLOSEME 07/14
(Reporter)

Comment 12

10 years ago
Anthony,

I have temporary put the applet in the following web page:
http://neslog.dnsalias.net/BugShowStatus.html

The java file is in :
http://neslog.dnsalias.net/BugShowStatus.java

You can (re)compile it with the command:
# javac BugShowStatus.java

Tell me if can can run the applet.
---
Armand Bendanan
ok...I am seeing what you are seeing now.  So the status bar shows "position: N49".  What is supposed to be displayed?
(Reporter)

Comment 14

10 years ago
According to the source code:
showStatus("Position : N49° 28' 32''");

The status bar SHOULD display:
Position : N49° 28' 32''

It seams that the status bar stop the display of the string BEFORE the '°' character.

Bizarre, no?

Comment 15

5 years ago
related, bug 314460
Depends on: 314460
Priority: -- → P5

Comment 16

5 years ago
Java was not passing a UTF8 string correctly. Nothing we can fix. I think Java fixed this in the meantime though.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago5 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.