With ui.key.contentAccess==4, accesskey='{' (etc.) no longer works

RESOLVED DUPLICATE of bug 357101

Status

()

Firefox
Keyboard Navigation
RESOLVED DUPLICATE of bug 357101
11 years ago
11 years ago

People

(Reporter: Timwi, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.8.1) Gecko/20061010 Firefox/2.0
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.8.1) Gecko/20061010 Firefox/2.0

(This bug report assumes a US English keyboard layout. The same bug applies to other keyboard layouts, but may involve different characters.)

In Firefox 1.5 it was possible to access elements with accesskey='[' by pressing Alt+[, and elements with accesskey='{' by pressing Alt+Shift+[ (which is Alt+{).

In Firefox 2.0, with ui.key.contentAccess set to 4 (which is NOT the default), I expect the behaviour to be equivalent to Firefox 1.5's. However, Alt+{ no longer works (and nor does Alt+}, Alt+:, Alt+<, etc.etc.etc., i.e. all the keys that require Shift).

Reproducible: Always

Actual Results:  
Nothing happens.

Expected Results:  
Element should be focused just like in Firefox 1.5.

Comment 1

11 years ago
Depending on how bug 357101 is fixed, this might no longer be directly supported - in this case, a fix to bug 303192 will however ensure that those accesskeys can still be invoked through a menu.

*** This bug has been marked as a duplicate of 357101 ***
Severity: major → normal
Status: UNCONFIRMED → RESOLVED
Last Resolved: 11 years ago
OS: Windows 2000 → All
Hardware: PC → All
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.