Two sessions need to be maintained for two different accounts on the same host(e.g: Yahoo).

RESOLVED DUPLICATE of bug 117222

Status

()

RESOLVED DUPLICATE of bug 117222
12 years ago
3 years ago

People

(Reporter: pandu345, Unassigned)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.8.0.8) Gecko/20061025 Firefox/1.5.0.8
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.8.0.8) Gecko/20061025 Firefox/1.5.0.8

Sessions are not handled well - incase of same host.
This takes priority when we use firefox to test web based applications you worked with.A brief example would be you have two yahoo mail accounts say test1@yahoo.coom,test2@yahoo.com.Now you may want to perform some operations as test1 and some as test2.

When you log in as test1 and access some session protected urls you can do what ever you want.Now open a different firefox browser(or a different tab).Try the same url - it directly says logged in as test1.If you log out and log in as test2 and do some thing.Now come back to first browser it says test1 sessions is expired when you try to access protected urls.

So things requested is a session should be tied to particular tab or browser.This does not happen in Internet Explorer(Sorry for comparing).

Reproducible: Always

Steps to Reproduce:
1.Get two accounts on same host , e.g: two Yahoo Mail accounts - say test1, test2
2.Open one firefox browser ,go to http://mail.yahoo.com
3.Log in as test1, you should log in successfully.
4.Access some inbox or some thing.
5.Open a new firefox browser,go to http://mail.yahoo.com
6.It says already logged in as first user ,test1.
7.Now log out and log in as test2, it allows you do that
8.Access some inbox or some thing.
9.Now come back to first firefox browser, click on some protected url , check mail or compose.It should say session invalid or Expired.
10.Try the same on any competitive browser (e.g: Internet Explorer)
Actual Results:  
Session is shared among multiple browsers , this is not the expected behaviour.

Expected Results:  
Session should be tied to particular browser or tab.This does not happen in Firefox

It should allow you to log in as two different accounts at the same time and each should be able to perform operations.
(Reporter)

Updated

12 years ago
Version: unspecified → 1.5.0.x Branch

Updated

12 years ago
Whiteboard: DUPEME

Updated

12 years ago
Severity: major → normal
OS: Windows 2000 → All
Hardware: PC → All
Version: 1.5.0.x Branch → Trunk

*** This bug has been marked as a duplicate of 117222 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → DUPLICATE

Updated

5 years ago
Whiteboard: DUPEME
You need to log in before you can comment on or make changes to this bug.