Can no longer import trusted email cert

VERIFIED FIXED

Status

()

P1
normal
VERIFIED FIXED
12 years ago
12 years ago

People

(Reporter: kaie, Assigned: kaie)

Tracking

({regression, verified1.8.1.2})

1.8 Branch
regression, verified1.8.1.2
Points:
---
Bug Flags:
blocking1.8.1.2 +
wanted1.8.1.x +

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Assignee)

Description

12 years ago
We introduced a regression with bug 310446.

The regression causes us to fail importing email certs.
(Assignee)

Updated

12 years ago
Keywords: regression
Priority: -- → P1
(Assignee)

Comment 1

12 years ago
Created attachment 245431 [details] [diff] [review]
Patch v1
Attachment #245431 - Flags: review?(rrelyea)
(Assignee)

Updated

12 years ago
Blocks: 354525

Comment 2

12 years ago
Kai, you also need to do something about
  CERTCertificateListCleaner chainCleaner(certChain);
which is now initialized with certChain=nsnull.  There are
two instances of chainCleaner.

Comment 3

12 years ago
I see that CERTCertificateListCleaner takes a reference of its
argument, so the code is correct.  Please ignore my previous comment.

Comment 4

12 years ago
Comment on attachment 245431 [details] [diff] [review]
Patch v1

r+ = relyea.
Attachment #245431 - Flags: review?(rrelyea) → review+
(Assignee)

Comment 5

12 years ago
fixed on trunk.
Status: NEW → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → FIXED
(Assignee)

Comment 6

12 years ago
Comment on attachment 245431 [details] [diff] [review]
Patch v1

We should get this regression fix into Thunderbird 2.

Not sure whether to ask for approval1.8.1.1 or approval1.8.1.2
Attachment #245431 - Flags: approval1.8.1.2?
Attachment #245431 - Flags: approval1.8.1.1?

Comment 7

12 years ago
Kai:  We are done with 1.8.1.1, so nominating for 1.8.1.2.  Also cc'ing mscott so this bug doesn't get lost for Thunderbird 2 (since there is no flag for it here).
Flags: wanted1.8.1.x+
Flags: blocking1.8.1.2?
(Assignee)

Updated

12 years ago
Attachment #245431 - Flags: approval1.8.1.1?

Updated

12 years ago
Flags: blocking1.8.1.2? → blocking1.8.1.2+

Comment 8

12 years ago
Comment on attachment 245431 [details] [diff] [review]
Patch v1

Approved for 1.8 branch, a=jay for drivers.
Attachment #245431 - Flags: approval1.8.1.2? → approval1.8.1.2+

Comment 9

12 years ago
Comment on attachment 245431 [details] [diff] [review]
Patch v1

r=wtc.
Attachment #245431 - Flags: review+

Comment 10

12 years ago
I checked in the patch on the MOZILLA_1_8_BRANCH.
Keywords: fixed1.8.1.2
Verified fixed for 1.8.1.2 with Mozilla/5.0 (Windows; U; Windows NT 5.2; en-US; rv:1.8.1.2pre) Gecko/20070104 Thunderbird/2.0b1 Mnenhy/0.7.4.10002 and my personal  thawte email cert. 
Status: RESOLVED → VERIFIED
Keywords: fixed1.8.1.2 → verified1.8.1.2
Duplicate of this bug: 357010
What presently-released versions of FF 2 (if any) contain this fix?
(Assignee)

Comment 14

12 years ago
Nelson, 1.8.1.2 is equivalent to Firefox 2.0.0.2, which was the first version that contains the fix.
You need to log in before you can comment on or make changes to this bug.