Throbber spins after document.write

RESOLVED DUPLICATE of bug 81980

Status

()

Firefox
General
RESOLVED DUPLICATE of bug 81980
12 years ago
5 years ago

People

(Reporter: Jerry Baker, Unassigned)

Tracking

2.0 Branch
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

12 years ago
In Firefox 2.0 the throbber continues to spin after a document.write ... even when using document.close().
(Reporter)

Comment 1

12 years ago
It seems only to happen if the document.write originates from a bookmarklet. Use the following code for a bookmarklet on the personal toolbar and press it a couple of times:

var ub=65535;var lb=1;for(i=0;i<200;i++){document.write(Math.floor((Math.random()*(ub-lb))+lb)+'<br>');}document.close()
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1) Gecko/20061109 BonEcho/2.0

Dupe of Bug 81980. It stops here when using document.close().
(Reporter)

Comment 3

12 years ago
The reason I mentioned that it doesn't stop with document.close() is because it actually doesn't stop with document.close(). That would make it not a dup of bug 81980. I have been a CC member of bug 81980 for more than a year so I am aware of that issue.
Do you have a testcase? This works for me...
(Reporter)

Comment 5

12 years ago
Yes. Create the bookmarklet I posted in comment #1 and then use it a couple times.
That bookmark creates a new document at loads, then writes to it 200 times before closing it. If you click it again before the 200 writes are over (which may happen if you're clicking it many times quickly), a new document will be created before the close() call, which would make this an edge case of bug 81980.
(Reporter)

Comment 7

12 years ago
You don't have to press it rapidly, just twice in the same Firefox session (and in the same tab/window without loading any other documents in between). So if you press it once, wait ten minutes and press it again you'll see the spinning throbber.
This bug is part of a query for Firefox bugs that have Status set to NEW, but have version field set to 2.0 or older and have not changed in over 800 days.

http://tiny.cc/forgottennewbugs

If you still see this bug, or if it is still valid with Firefox 3.6.10 or a firefox 4 nightly build, please update the version field and steps to reproduce.
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 81980
You need to log in before you can comment on or make changes to this bug.