Identity editor needs a confirmation dialog on 'Delete'

RESOLVED FIXED in Thunderbird 17.0

Status

MailNews Core
Account Manager
--
enhancement
RESOLVED FIXED
11 years ago
5 years ago

People

(Reporter: Dave Belfer-Shevett, Assigned: aceman)

Tracking

(Blocks: 1 bug)

Trunk
Thunderbird 17.0
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment, 1 obsolete attachment)

5.57 KB, patch
squib
: review+
Ian Neal
: review+
bwinton
: ui-review+
Details | Diff | Splinter Review
(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.0.7) Gecko/20060830 Firefox/1.5.0.7 (Debian-1.5.dfsg+1.5.0.7-2)
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.0.7) Gecko/20060830 Firefox/1.5.0.7 (Debian-1.5.dfsg+1.5.0.7-2)

When editing Identities, it is ridiculously simple to mistakenly delete an identity you've already setup.  Without a 'Cancel' button, this is an irreversible one-click function, with somewhat dire circumstances.

Either the Identities editor needs a 'cancel' function to undo changes, or the Delete button needs an 'Are you sure?' dialog.

Reproducible: Always

Steps to Reproduce:
1.Go to Accounts->Manage Identities
2.Spend 10 minutes setting up a new identity
3.Instead of hittin [ok], the mouse gets jostled and you hit Delete instead.
4.Curse loudly.

Actual Results:  
Identity is gone with no recourse.

Expected Results:  
Prompted with "Are you sure you want to delete this identity?"

Comment 1

11 years ago
Confirming RFE.
Severity: normal → enhancement
Status: UNCONFIRMED → NEW
Ever confirmed: true
OS: Windows XP → All
Hardware: PC → All

Updated

9 years ago
Assignee: mscott → nobody
(Assignee)

Comment 2

5 years ago
Bwinton, are you OK with this?

Mistakenly deleting and then recreating the identity may assign it a different id so existing messages referencing the old ID may now have a problem (like Drafts or Unsent). But for the user the identity will look the same (same address and other values) so he may not understand it.
Assignee: nobody → acelists
Component: Account Manager → Account Manager
Product: Thunderbird → MailNews Core
QA Contact: account-manager → account-manager
Version: unspecified → Trunk
(Assignee)

Comment 3

5 years ago
Created attachment 638023 [details] [diff] [review]
patch
Attachment #638023 - Flags: ui-review?(bwinton)
(Assignee)

Updated

5 years ago
Status: NEW → ASSIGNED
Comment on attachment 638023 [details] [diff] [review]
patch

I think it's close, but not quite there.

As you can see in http://dl.dropbox.com/u/2301433/Screenshots/DeleteWhat.png there's no indication of which identity was selected (and indeed, it wasn't the "blaketestwinton@gmail.com" identity, so the dialog was both incomplete and misleading ;).  I suggest something like:
+-------------------------------------------------+
| Deleting identity for blaketestwinton@gmail.com |
|                                                 |
| Are you sure you want to delete the identity    |
| test@test.test?                                 |
|                                [Cancel]   [OK]  |
+-------------------------------------------------+

In general, people don't read dialogs, and so it would be way better if we could support an "Undo" here instead, but since I suspect that's much more work, I think going this way is the best we can do in the short term.

So, ui-r-, so that I can see the new dialog wording, but other than that, it seems okay.

Thanks,
Blake.
Attachment #638023 - Flags: ui-review?(bwinton) → ui-review-

Comment 5

5 years ago
(In reply to Blake Winton (:bwinton - Thunderbird UX) from comment #4)
> +-------------------------------------------------+
> | Deleting identity for blaketestwinton@gmail.com |
> |                                                 |
> | Are you sure you want to delete the identity    |
> | test@test.test?                                 |
> |                                [Cancel]   [OK]  |
> +-------------------------------------------------+

Let's use "Delete" instead of "OK" here. :)
(Assignee)

Comment 6

5 years ago
Created attachment 643592 [details] [diff] [review]
patch v2

Yes, undo would need more thought. Maybe in a new bug if somebody requests it.

I fixed the strings and button as you both requested.
Attachment #638023 - Attachment is obsolete: true
Attachment #643592 - Flags: ui-review?(bwinton)
Attachment #643592 - Flags: review?(squibblyflabbetydoo)
(Assignee)

Updated

5 years ago
Blocks: 314806
Comment on attachment 643592 [details] [diff] [review]
patch v2

Looks good.  ui-r=me!

Thanks,
Blake.
Attachment #643592 - Flags: ui-review?(bwinton) → ui-review+

Comment 8

5 years ago
Comment on attachment 643592 [details] [diff] [review]
patch v2

Review of attachment 643592 [details] [diff] [review]:
-----------------------------------------------------------------

Looks good. r=me
Attachment #643592 - Flags: review?(squibblyflabbetydoo) → review+
(Assignee)

Updated

5 years ago
Attachment #643592 - Flags: review?(iann_bugzilla)

Updated

5 years ago
Attachment #643592 - Flags: review?(iann_bugzilla) → review+
(Assignee)

Updated

5 years ago
Keywords: checkin-needed

Comment 9

5 years ago
Checked in: http://hg.mozilla.org/comm-central/rev/42234d57ebdc
Status: ASSIGNED → RESOLVED
Last Resolved: 5 years ago
Keywords: checkin-needed
Resolution: --- → FIXED
Target Milestone: --- → Thunderbird 17.0
(Reporter)

Comment 10

5 years ago
As the originator of this bug almost 6 years ago, I'm ecstatic to see it resolved and committed.  Thank you everyone who worked on it!
(Assignee)

Comment 11

5 years ago
Hi, thanks for your reply!
When you try a version of TB (17 and up) that has the bug fixed, please change the status to VERIFIED. Thanks.
(Assignee)

Updated

5 years ago
Blocks: 792334
You need to log in before you can comment on or make changes to this bug.