Closed Bug 360939 Opened 15 years ago Closed 13 years ago

Applescript support. Penelope should be scriptable via Applescript

Categories

(Penelope Graveyard :: General, enhancement, P5)

PowerPC
macOS
enhancement

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 243543

People

(Reporter: mdudziak, Assigned: sdorner)

References

Details

This is a generic placeholder bug for Applescript support in Penelope. Feel free to add comments indicating specific features you would like to see scriptable. For a start, Penelope should support:

- Check mail events
- Creating and sending new messages (with attachments, specifying Personality (account), signature, etc.).

- What do you use the most? Add comments letting us know.
I would like there to be a filter action to execute a script (AppleScript for Macs) or other program with the message available to it.
Status: NEW → ASSIGNED
Bug #361641 is a request for filter driven AppleScript execution.

https://bugzilla.mozilla.org/show_bug.cgi?id=361641
I need to be able to inspect the current e-mail message and gets its body and various headers, as well as the current selection. Eudora allowed me to do this. In Thunderbird I fake it with system UI events activating menu items such as View Source. Then I copy the entire message and grep through the headers. Bleah. 
Duplicate of this bug: 371904
I vote for including junk score as a message property so messages could be processed after scoring by junk plug-ins. As it stands, one has to manually open the Junk folder to run filters on its messages after they have been routed there by a plug-in.
Also, a vote for a command to filter selected messages or a mailbox.
Yes, Applescriptability is essential. Else why stop using the old Eudora?

(Though it would be nice if there were some online resources that were less than five years old for Eudora scripting.)

Being able to get the raw source of the message is key for some of my scripts. 
The minimum for Penelope scriptability should be replicating the full functionality of the Mac Eudora AppleScript dictionary.  Adding the ability to pass a message to a script as a filter action would be nice as an addition. 
(In reply to comment #1)
> I would like there to be a filter action to execute a script (AppleScript for
> Macs) or other program with the message available to it.
> 

I would also like the possibility of running a script as a possible filter action, but with Windows, what would it be? AutoHotKey? It is free, simple, powerful and flexible, but no one has got round to developing an IDE for it yet.

Any suggestions?
(In reply to comment #9)
> (In reply to comment #1)
> > I would like there to be a filter action to execute a script (AppleScript for
> > Macs) or other program with the message available to it.
> > 
> 
> I would also like the possibility of running a script as a possible filter
> action, but with Windows, what would it be? AutoHotKey? It is free, simple,
> powerful and flexible, but no one has got round to developing an IDE for it
> yet.
> 
> Any suggestions?

It seems like the "script as filter action" feature has an obvious path on Windows: Windows Script Host. 

it is harder to figure out how to replicate the existing Eudora/Mac scripting support on Windows, and it actually might not be feasible at all. 
I wouldn't want to get involved with MSH which only interacts with languages I'm not familiar with.

However, is a "Run" option not feasible? Many scripts can be compiled to exe format and indeed uncompiled scripts will run in XP if their file extensions are configured so that Open is the default action.

A minor consideration is that modern programs, which does not include cmd.exe, do not require double quotes when there are spaces in the path.

I certainly don't think this is an urgent matter, but I'd like to see it considered.
I notice 8.0b1 has even less AppleScript than Thunderbird; that is to say, none at all. Perhaps this is just a missing dictionary? 

Still a solid product even if AppleScript doesn't make the cut for 8.0, but that might be enough to keep me with ThunderBird for the time being. As weak as its AppleScript support is relative to classic Eudora, it at least lets me do something. 
(In reply to comment #12)
> I notice 8.0b1 has even less AppleScript than Thunderbird; that is to say, none
> at all. Perhaps this is just a missing dictionary? 
> 
> Still a solid product even if AppleScript doesn't make the cut for 8.0, but
> that might be enough to keep me with ThunderBird for the time being. As weak as
> its AppleScript support is relative to classic Eudora, it at least lets me do
> something. 
> 


This is because Eudora is based on the Thunderbird 2.x line, and not the Thunderbird 3.x line. We plan to move Eudora to the 'trunk' at some point, so we should get the Applescript (that Thunderbird has) at that point.

Matt
Duplicate of this bug: 400482
Priority: -- → P5
Status: ASSIGNED → RESOLVED
Closed: 13 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 243543
You need to log in before you can comment on or make changes to this bug.