Closed Bug 360976 Opened 15 years ago Closed 3 years ago

Mailbox Display: Allow displayed subject to be edited (editable Subject)

Categories

(Penelope Graveyard :: Mail Window, enhancement, P3)

enhancement

Tracking

(Not tracked)

RESOLVED WONTFIX

People

(Reporter: mdudziak, Assigned: dwiggins)

References

(Depends on 1 open bug)

Details

Eudora allows you to edit the subject that is displayed in the message list (TOC). This does not change the actual message subject, just the one displayed to the user. This allows for adding subjects to messages that do not have them, or changing the subject to something that is more useful.

Penelope should allow the user to edit the subject displayed to the user. If you agree, vote for this bug.
Depends on: 91106
Where is this feature?  I use the Windows version and have never noticed this feature.  I would vote for it if I were certain it's really an existing Eudora feature.
Joseph, to do this, simply open a message in its own window. At the top of the window, the subject line is in an editable box: you can change it at will. This only affects the displayed subject line: the actual message subject remains the same (unless you use pencil editing to change).
Of course!  I remember now.  How could I have forgotten this?  Hmm... Well I guess I shouldn't start using any rediscovered Eudora features until I'm sure they will be in Penelope and Penelope can import my very large email archives without losing any such changes. I vote for this one.
I vote for this too.  Very helpful feature.
Agreed. This is a great Eudora feature, especially when dealing with correspondents who don't put anything in the subject line.
Very important for adding a subject for those who refuse to use them.
Status: NEW → ASSIGNED
Although I know the risks of creeping elegance --
It would be nice if the changed subject line were in a different color, so if I am talking about the email later to the sender, I won't say "You sent it on May 16.  The Subject Line was Eat More Bugs" and have the sender say "I don't see any email like that in my Sent folder." and I say "I'm looking right at it" and he says ... ... ...

Or, if I later forward it to someone, I'm reminded I've changed the subject line.
Assignee: mozilla-bugs → sdorner
Status: ASSIGNED → NEW
Note that clicking the "subject" column header sorts messages by _edited_ subject.
Apologies if this seems obvious, but it is key to the great power/usefulness of this feature. 
For example, I get a lot of mail about events; by adding the event date as an ISO date (yyyymmdd) at the beginning of the subject line, and sorting the folder by subject, I get a listing in diary order.
Another example, my message filters include certain spam and virus traps. By having these filters mark the beginning of the subject line to identify the filter that has fired, it becomes easy to sort the spam trap folder by category, which makes reviewing it for false hits much quicker and easier. 
Hope this is useful info.
Note that the Eudora message window displays _two_ message subject fields for received messages(initially identical)
 - one in the window header - this is the editable field, shown also in the mailbox listing;
 - one in the message headers in the window body - this is the original, and does not change. 
So the conversation hypothesized in Comment #7 isn't too likely in my experience.
However Eudora uses the edited subject for read notifications, which might be a mistake - I was mortified to see "Due Course Dept." flash past on its way out...
Status: NEW → ASSIGNED
Priority: -- → P3
Target Milestone: --- → 0.5
I vote for this bug. It's a useful, if minor, feature.
I vote for this feature. It is one way to organize emails dealing with the same subject but not using the same subject contents.
I consider this a major feature. The lack of it was a deal-breaker when fellow IT staffers tried to pressure me to switch to Apple Mail. Virtually all my work comes in via email; at best, maybe 50 percent of those messages have useful subject lines. With a to-do box of several hundred messages, I have to be able to quickly scan them, so I regularly edit subject lines. My efficiency would plummet if I lost this ability.
Assignee: sdorner → dwiggins
Status: ASSIGNED → NEW
Status: NEW → ASSIGNED
I've just moved to Eudora 8, and am finding some of beloved features missing.  This feature too is incredibly helpful and is something I use often to correct some of my more lazy co-worker's subject lines.  Please ad it back into the software as soon as possible.  Best Regards.
Duplicate of this bug: 477607
Target Milestone: 0.5 → ---
This is one of the reasons I still use Eudora also. Like Carol, I tried to go with Apple Mail, but like her, I so most of my business via email and rely on being able to edit subject lines.  I also edit body content.
For me, this is a critical feature as well, as long with the ability to IMPORT EDITED SUBJECT LINES from Eudora7. I have thousands of messages that are edited and classified that way and I will not switch to OSE before that feature has been implemented.
I also voted for editable subject lines!

Basically there's a need to be able to "annotate" email that comes in. I don't care if it changes the original email or is added as another layer of information, but I want to be able to fix non-descriptive titles and make comments right on the email. (Rather than, say, forwarding a copy of the email with my comments to myself -- a poor workaround.)
Penelope didn't see any activity in the vcs for the last 8 years, closing.
Status: ASSIGNED → RESOLVED
Closed: 3 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.