Junk Handling: Support third-party applications such as SpamSieve

RESOLVED DUPLICATE of bug 353839

Status

Penelope
General
P5
enhancement
RESOLVED DUPLICATE of bug 353839
12 years ago
9 years ago

People

(Reporter: Matt Dudziak, Assigned: Matt Dudziak)

Tracking

Details

(Assignee)

Description

12 years ago
From the wiki:
My understanding is that SpamSieve does not function with Thunderbird, currently, because no hooks are provided to do so. I'm simply unwilling to use a mailreader at this point that does not support SpamSieve. Therefore, I'd like to see Penelope support third-party spam filters, such as SpamSieve, and do so in a *full* manner, as opposed to the way that Eudora does it, which, as I understand, doesn't pass on much information at all about embedded images that can be a useful part of spam filtering, too.

Penelope should support a plugin architecture that allows for third-parties such as SpamSieve to access the full received message and act on that message to do such things as assign a junk score, etc. If you agree, vote for this bug.

Comment 1

12 years ago
This sounds like it should be a core Thunderbird feature request, but I think maybe Penelope would require some additional enhancements on top of what-ever they do in Thunderbird. At best, this seems like a Penelope v1.x or v2 feature to me.

Matt, you don't use Eudora or Thunderbird; why is this feature request here?  Do you have similar feature request for Thunderbird?  
(Assignee)

Comment 2

12 years ago
(In reply to comment #1)
> This sounds like it should be a core Thunderbird feature request, but I think
> maybe Penelope would require some additional enhancements on top of what-ever
> they do in Thunderbird. At best, this seems like a Penelope v1.x or v2 feature
> to me.
> 
> Matt, you don't use Eudora or Thunderbird; why is this feature request here? 
> Do you have similar feature request for Thunderbird?  
> 


Penelope is based on Thunderbird, and many features that go into Thunderbird will go into Penelope. The Thunderbird folks may or may not incorporate changes made for Penelope into Thunderbird.

The reason I am entering these here is so that it is on OUR radar and not lost in the hundreds (thousands?) of bugs filed against Thunderbird. As I said, any change we make can be used by the Thunderbird folks as well...

Oh, and I just copied someone else's request from the WIKI and pasted it in. This was not my personal request....

Matt

Comment 3

11 years ago
I'm glad the Spamsieve issue was raised. Focusing on its use with Eudora: Eudora forces Spamsieve (and other junk plug-ins) to run -before- any user filters. Other email clients are more flexible. This is especially important if one wants to run one's whitelist filters first to reduce false positives. I want to do that -and- run other filters after Spamsieve. Eudora should allow placement of 3rd party junk plug-ins anywhere in the filter list.

Comment 4

11 years ago
I use Norton's spam filter, but the concept is the same.  Hooks for all commercial spam filters should be included.
(Assignee)

Updated

11 years ago
Status: NEW → ASSIGNED
(Assignee)

Updated

10 years ago
Priority: -- → P5
(Assignee)

Updated

9 years ago
Status: ASSIGNED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 353839
You need to log in before you can comment on or make changes to this bug.