Closed Bug 361185 Opened 18 years ago Closed 18 years ago

Firefox trashes Internet Explorer configuration

Categories

(Firefox :: Installer, defect)

x86
Windows XP
defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 255225

People

(Reporter: dror.tir, Unassigned)

Details

User-Agent:       Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1; SV1)
Build Identifier: 

1. once installed, and made default browser, IE cannot become default browser: Firefox writes itself in a way that IE still "think" it is default.

2. for this reason, I UNINSTALLED Firefox - but FIREFOX DIDN'T RESTORE IE AS THE ACTION FOR HTTP, HTTPS - and I got the "search for app" when clicking a link in Email.

NOTE: I installed Firefox because I WANT an alternative for IE - but I don't like someone to FORCE me use one or the other...

Reproducible: Didn't try

Steps to Reproduce:
0. start with IE as default browser. can click and open links (e.g. in Start/Run dialog, type "http://mozilla.org"
1. install firefox, make it default app.
2. launch IE, make it "check for being default every time"
3. now when I exit and re-launch IE, it doesn't ask to make it default.
4. uninstall Firefox
5. try to open the link in step 0 - it won't start. need to manually fix the registry.
Looks like a DUPLICATE of bug 255225.
in case of uninstall yes, it's a dupe of bug 255225. But it's not just as simple as a restoring of IE of the default browser. For example, who says that it has to be IE ? Why not Opera ? But that's a discussion for bug 255225.

Anyway, you can force IE to check if it's the default browser - go to Control Panel -> Internet Options - > Programs. Then start up IE, and it will ask you if it should be the default again. 

*** This bug has been marked as a duplicate of 255225 ***
Status: UNCONFIRMED → RESOLVED
Closed: 18 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.