In suiterunner preferences, advanced -> Mousewheel pane doesn't display

RESOLVED FIXED

Status

defect
RESOLVED FIXED
13 years ago
13 years ago

People

(Reporter: standard8, Assigned: standard8)

Tracking

Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments, 1 obsolete attachment)

Assignee

Description

13 years ago
When attempting to view advanced -> mousewheel, the pane doesn't display and the following error is displayed instead:

XML Parsing Error: undefined entity
Location: chrome://communicator/content/pref/pref-mousewheel.xul
Line Number 102, Column 7:      <tab label="&usingWheelAndAlt.label;"/>

This looks like pref-mousewheel.dtd isn't being included - but as far as I can tell it is. So I'm not quite sure what is happening here.
Assignee

Comment 1

13 years ago
The problem here is that pref-mousewheel.xul calls up pref-mousewheel.dtd which in turn defines:

<!ENTITY usingWheelAndAlt.label          "&altKey.label;">
<!ENTITY usingWheelAndCtrl.label         "&ctrlKey.label;">
<!ENTITY usingWheelAndShft.label         "&shiftKey.label;">

The *Key.label etc are defined in http://lxr.mozilla.org/seamonkey/source/xpfe/global/resources/locale/en-US/unix/platformDialogOverlay.dtd which we're no longer including in suiterunner builds.

Interestingly ff does it like this:

http://lxr.mozilla.org/seamonkey/source/browser/locales/en-US/chrome/help/platformStrings.dtd#26

So I'm not quite sure of what we should really be doing here.
Assignee

Comment 2

13 years ago
Posted patch Patch v1 (obsolete) — Splinter Review
I'm still checking this, but I think this is the way to go.
Assignee: prefs → bugzilla
Status: NEW → ASSIGNED
Assignee

Comment 3

13 years ago
Posted patch Patch v1aSplinter Review
This patch works on linux xpfe & toolkit versions. I think windows should be ok, as turboDialog.xul used to need platformDialogOverlay.dtd but doesn't appear to now, pref-winhooks.xul doesn't seem to need that dtd either.

The only change from Patch v1a is that I changed some tabs to spaces in the platformCommunicatorOverlay.dtd files - I wanted to sort out the lining up, and ended up changing most of those files.
Attachment #246394 - Attachment is obsolete: true
Attachment #246408 - Flags: superreview?(neil)
Attachment #246408 - Flags: review?(kairo)

Comment 4

13 years ago
Comment on attachment 246408 [details] [diff] [review]
Patch v1a

r=me on those changes. Note that I can't test Windows as well, I hope Neil will be able to take a look on that being OK.
I like how a suiterunner patch doesn't need to make a difference between xpfe SeaMonkey and suiterunner ;-)
Attachment #246408 - Flags: review?(kairo) → review+

Updated

13 years ago
Attachment #246408 - Flags: superreview?(neil) → superreview+
Assignee

Comment 5

13 years ago
Patch checked into trunk.
Status: ASSIGNED → RESOLVED
Closed: 13 years ago
Resolution: --- → FIXED
Assignee

Updated

13 years ago
Depends on: 361883
Assignee

Comment 6

13 years ago
I backed out the xpfe parts of patch v1a to fix the regression detailed in bug 361883. Not sure how I missed that.

This means I need to file a follow up patch to remove some now obsolete prefs from platformDialogOverlay.dtd
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
Assignee

Comment 7

13 years ago
This patch removes the strings from the xpfe dtd files that are no longer used - because we now have them in platformCommunicatorOverlay.dtd.
Attachment #247272 - Flags: review?(kairo)

Comment 8

13 years ago
Comment on attachment 247272 [details] [diff] [review]
Remove obsolete xpfe strings

Looks good to me :)
Attachment #247272 - Flags: review?(kairo) → review+
Assignee

Comment 9

13 years ago
Remove obsolete xpfe strings patch checked in -> fixed.
Status: REOPENED → RESOLVED
Closed: 13 years ago13 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.