make it possible to create templates [extension fodder]

RESOLVED WONTFIX

Status

Calendar
General
--
enhancement
RESOLVED WONTFIX
12 years ago
4 years ago

People

(Reporter: Taraman, Unassigned)

Tracking

Details

(Whiteboard: [extension fodder])

Attachments

(1 attachment)

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; de; rv:1.8.1) Gecko/20061010 Firefox/2.0
Build Identifier: Lightning 0.4a1 (build 1006111906) in Thunderbird 1.5.0.8 (20061025)

It would be great, if you could create templates for events, that don't reoccur regularly, so you can add them easily.
I would suggest to add an item to the right-click menu to add an event from a tmplate or to define an existing event as a template.

Reproducible: Always
Duplicate of this bug: 304919
With the new event dialog, maybe even a sidebar similar to the contacts sidebar on the message compose window would be a good idea. CCing Christian for a UI proposal.
OS: Windows XP → All
Hardware: PC → All
If anyone else feels like whipping up UI for this, feel free to attach screenshots.
Keywords: uiwanted
Created attachment 339749 [details]
Template UI proposal - v1

In case someone is interested, I would imagine something like this.

Updated

10 years ago
Status: UNCONFIRMED → NEW
Ever confirmed: true
Keywords: uiwanted
I think this should be done in an extension.
Summary: make it possible to create templates → make it possible to create templates [extension fodder]
Duplicate of this bug: 274455
From bug 274455:

It would also be nice to automatically load templates based on the selected category, i.e "Birthday" and "Anniversary" should automatically make the event allday and recur yearly.
Duplicate of this bug: 417783
Duplicate of this bug: 382589

Comment 10

7 years ago
Excellent idea. I believe most people have a limited number (smaller than 10) of event types they frequently create. 

I'd add that it should be possible to specify in which calendar events based on a template will be created.

Double clicking on the calendar should create an event based on the default template. Right-mouse clicking on the calendar should produce a context menu with selection of templates among other things.
Duplicate of this bug: 476937
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → WONTFIX
Whiteboard: [extension fodder]
You need to log in before you can comment on or make changes to this bug.