Unable to create new profile with -profilemanager

VERIFIED WORKSFORME

Status

defect
--
major
VERIFIED WORKSFORME
13 years ago
3 years ago

People

(Reporter: stevee, Unassigned)

Tracking

({regression})

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

13 years ago
1. Start firefox with -profilemanager
2. Click "Create new profile"

Expected:
- Dialog displayed that starts with "Minefield stores information about your settings and perforances in your perosnal profile. <snip>" that has three buttons.. "< Back" (greyed out) "Next >" and "Cancel". Clicking "Next >" should take you to a dialog where you can name your new profile.

Actual:
- Screen shows that starts with "Minefield stores information about your settings and perforances in your perosnal profile." but there is no "Next >" button, only "< Back", "Finish" and "Cancel". None of the three buttons do anything when you click them.

Works
- Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.9a1) Gecko/20061122 Minefield/3.0a1 ID:2006112204 [cairo]

Broken
- Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.9a1) Gecko/20061122 Minefield/3.0a1 ID:2006112211 [cairo]
- Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.9a1) Gecko/20061122 Minefield/3.0a1 ID:2006112213 [cairo]

Bonsai Regression Range
- http://bonsai.mozilla.org/cvsquery.cgi?treeid=default&module=PhoenixTinderbox&branch=HEAD&branchtype=match&dir=&file=&filetype=match&who=&whotype=match&sortby=Date&hours=2&date=explicit&mindate=2006-11-22+03&maxdate=2006-11-22+112&cvsroot=%2Fcvsroot
(Reporter)

Updated

13 years ago
Component: General → General
Product: Firefox → Core
QA Contact: general → general
(Reporter)

Updated

13 years ago
Component: General → Profile: BackEnd
QA Contact: general → profile-manager-backend
looks like Bug 333078
Severity: normal → major
(Reporter)

Comment 2

13 years ago
Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.9a1) Gecko/20061122 Minefield/3.0a1 ID:2006112215 [cairo]
Now fixed after backout of bug 333078 (XPCOM cycle collector).
(Reporter)

Comment 4

13 years ago
There is no problem shown on:
- Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.9a1) Gecko/2006112304 Minefield/3.0a1 [reflow branch from 20061031]
- Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.8.1.1pre) Gecko/2006112303 BonEcho/2.0.0.1pre
So I'm punting this over to Core:GFX:Thebes on suggestion.
Component: Profile: BackEnd → GFX: Thebes
QA Contact: profile-manager-backend → thebes
(Reporter)

Comment 5

13 years ago
Ignore comment 4; wrong bug open.
Component: GFX: Thebes → Profile: BackEnd
QA Contact: thebes → profile-manager-backend
Cycle collector has re-landed and profile manager WFM (I was able to create and delete a profile just fine).

Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a2pre) Gecko/20070106 Firefox/3.0a2pre
Status: NEW → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → WORKSFORME
(Reporter)

Comment 7

13 years ago
Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.9a2pre) Gecko/20070105
Minefield/3.0a2pre ID:2007010509 [cairo]
WFM
--> VERIFIED
Status: RESOLVED → VERIFIED
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.