Closed Bug 36159 Opened 20 years ago Closed 20 years ago

sending unsent messages fails

Categories

(SeaMonkey :: MailNews: Message Display, defect, P3, major)

x86
Linux

Tracking

(Not tracked)

VERIFIED FIXED

People

(Reporter: blizzard, Assigned: sspitzer)

Details

(Whiteboard: [nsbeta2+])

Attachments

(1 file)

Trying to send unsent messages fails.  I get this javascript message:

JavaScript error:
chrome://messenger/content/widgetglue.js line 288: getIdentityForSelectedServer
is not defined
blizzard - are you actually in the unsent folder when you access this command?
Severity: normal → major
QA Contact: lchiang → esther
I tried it both ways.  I always get the same error.
esther - can you reproduce this bug?
Status: UNCONFIRMED → NEW
Ever confirmed: true
Still happening??
Alec, looks like you created widgetGlue.js.  Please reassign or keep as 
appropriate.
Assignee: selmer → alecf
adding ducarroz and sspitzer, feel free to take this from me.
I'm not sure why we're trying to call this function when sending the message
adding rhp and putterman, but I can take a look into this.

my first guess:  code has been moved around into different js files (for general
cleanup and to support stand alone message window.)

if I'm correct, it should be a one line fix.
Assignee: alecf → sspitzer
I wonder if this is why 10344 has suddenly been updated to a major regression.  
My guess is that this is because of the fact that I moved getIdentityForServer 
up into mailWidgetOverlay.js and changed it to take the server you want to get 
the identity for.
I have a patch that fixes the js error, but sending unsent still doesn't work 
and is probably related to the other bug I mentioned.
the local mail server will not have an identity.  so we have to handle that
case.

putterman, you want to take this bug?
I'll take the bug about the js errors because I caused that.  What do we have to 
do for the local folder case, just handle a null pointer in the send unsent 
messages code?
Assignee: sspitzer → putterman
putterman, once you check in your changes to fix the js error, re-assign to me,
and I'll investigate fix the unset message problem, and make sure we do the
right thing for "local folders".
Assignee: putterman → sspitzer
I think putterman has checked in his part of this fix, now I'll update and see 
why sending unsent messages isn't working.
marking m17, nsbeta2
Status: NEW → ASSIGNED
Keywords: nsbeta2
Target Milestone: --- → M17
Putting on [nsbeta2+] radar for beta2 fix. 
Whiteboard: [nsbeta2+]
fix in hand, but I want to test some more tomorrow, and get a review from rhp.

Target Milestone: M17 → M16
fixed,  sending unsent messages now works. 

also rosetta_mailnews.h is gone

I discovered that we are not setting or heeding the X-Mozilla-News-Host header
properly, so I'll log that bug (on me) and look into it.

Status: ASSIGNED → RESOLVED
Closed: 20 years ago
Resolution: --- → FIXED
Using build 2000-05-25 on mac and win98 and 2000-05-26 on linux this is fixed.  
Verified.
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.