Closed Bug 361634 Opened 13 years ago Closed 11 years ago

imip-bar should consider local status of iTIP/iMIP invitations

Categories

(Calendar :: E-mail based Scheduling (iTIP/iMIP), defect, trivial)

defect
Not set
trivial

Tracking

(Not tracked)

VERIFIED FIXED

People

(Reporter: bugzilla, Assigned: dbo)

References

Details

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a1) Gecko/20061121 Minefield/3.0a1
Build Identifier: thunderbird version 3 alpha 1 (20061122) + lightning 4a1 (2006112205)

the status of an invitation (added to calendar/not addedd yet) is not permanently remembered

Reproducible: Always

Steps to Reproduce:
1. recieve an outlook meeting invitation
2. click "add to calendar" button
3. button disappears
4. view some other mail, view the invitation again
5. "add to calendar" button is back



Expected Results:  
would expect to not show that button as long as the event is in my calendar
Clint, you know best about ITIP and iMIP support.
CONFIRMED.

We currently don't store the local status of the iMIP/iTIP invitation, so we always offer "Add to Calendar", even if you already have clicked it before.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Summary: outlook invitations added status not saved → imip-bar should consider local status of iTIP/iMIP invitations
now, that bug 334685 landed (accept and decline choices), behavior and error message is not really user friendly when you try again to accept an invitation :
Invitation could not be processed : Status 2147500037
Details : ID already exists for AddItem
Duplicate of this bug: 379428
Duplicate of this bug: 381698
OS: Windows XP → All
Hardware: PC → All
Clint, could you please provide an update on the status of this bug, since there has been some recent work on iTIP/iMIP for 0.8?
It's better but it's not solved.  It can't be solved until we actually have a centralized system for storing what invitations you recieved.

For example take these steps into account:
1. Get invitation
2. Decline invitation
3. Restart thunderbird
4. Look at invitation in step 1, it looks like you never declined it.  We have no way to persist that information right now.  And that's what this bug is really asking us to do.

We need a general way to persist information across all invitations.  An invitation manager sort of solution that will be the one stop shop for all invitations in the system regardless of where they came from (email or in-provider) and where they are going (email, in-provider, sms, or some other transport).
Component: Lightning Only → E-mail based Scheduling (iTIP/iMIP)
QA Contact: lightning → email-scheduling
This seems fixed in 0.9pre 2008061820.
Possibly it was fixed due to bug 421886?
(In reply to comment #8)
> This seems fixed in 0.9pre 2008061820

It seems to be mostly fixed, but I still see the problem in the following situations.

Situation one:
1) I decline an invitation but the Accept/Decline/Tentative buttons remain.

Situation two:
1) An attendee accepts my invitation and sends the corresponding iMIP email to me.
2) I click the Update button and all is good.
3) I switch to another email and then back to this one and I see the Update button again.
Depends on: 457203
Ought to be fixed with bug 457203.
Assignee: nobody → daniel.boelzle
Status: NEW → RESOLVED
Closed: 11 years ago
Resolution: --- → FIXED
Target Milestone: --- → 1.0
Checked with lightning build 20081130 -> VERIFIED.
Status: RESOLVED → VERIFIED
These bugs are likely targeted at Lightning 1.0b1, not Lightning 1.0. If this change was done in error, please adjust the target milestone to its correct value. To filter on this bugspam, you can use "lightning-10-target-move".
Target Milestone: 1.0 → 1.0b1
These bugs are likely targeted at Lightning 1.0b1, not Lightning 1.0. If this change was done in error, please adjust the target milestone to its correct value. To filter on this bugspam, you can use "lightning-10-target-move".
You need to log in before you can comment on or make changes to this bug.