Spaces don't wrap as they do in NN or IE textareas

VERIFIED DUPLICATE of bug 19265

Status

()

P3
trivial
VERIFIED DUPLICATE of bug 19265
19 years ago
17 years ago

People

(Reporter: neil, Assigned: rods)

Tracking

Trunk
x86
Windows 95
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

19 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Win95; en-US; m14) Gecko/20000417
BuildID:    M14; also occurs in 2000041708

In Netscape Navigator and Internet Explorer textareas, a wrapped line will never
begin with a space. However, in Mozilla a wrapped line will begin with a space
if the line wraps at the last column.

Reproducible: Always
Steps to Reproduce:
1. You need a textarea with wrap, such as "Additional Comments".
2. Type until the text is on the point of wrapping, then type a space.	
3. Alternatively, just type lots of spaces until the line wraps.


Actual Results:  The space will appear on the next line.

Expected Results:  NN and IE don't display the space.	

A couple of regressions I noticed in build 2000041708:

The TAB key inserts into a textarea as well as changing the focus.

The SPACE key sometimes scrolls the page. Clicking on the page and then in the
textarea makes this happen. Tabbing (but not shift-tabbing) stops this happening.

Comment 1

19 years ago
This is a DUP of bug 19265, "[TEXT] Word-wrap improperly breaks before space 
following last word", M17.

The other issues mentioned already have specific bug reports.

*** This bug has been marked as a duplicate of 19265 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 19 years ago
Component: HTML Form Controls → Editor
QA Contact: ckritzer → sujay
Resolution: --- → DUPLICATE

Comment 2

19 years ago
verified in 4/20 build.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.