Responsible person(s): New field/table for Products

RESOLVED DUPLICATE of bug 189627

Status

()

--
enhancement
RESOLVED DUPLICATE of bug 189627
12 years ago
12 years ago

People

(Reporter: kbenton, Unassigned)

Tracking

Details

(Reporter)

Description

12 years ago
I suggest that we need a "responsible persons" field that includes a product_id and userid cross-reference.

Why?  This would...

o Give administrators a reference of individuals that are authorized to approve naming and assignment changes
o Give responsible persons the ability to change the product name and/or component names as well as initialowner, initialqacontact, and the CC list under products that person is responsible for.
o Keep administrators from getting caught in the middle of implementation arguments.
o Give Bugzilla the ability to show users who to go to when they need to change a product's name, a component's name, or other administrative changes related to a product or component.
o Give responsible persons the ability to add / remove groups to products they're responsible for.

I suggest this implementation in the DB:

create table product_responsible_persons_map (
  product_id mediumint not null,
  userid mediumint not null,
  primary key (product_id, userid)
)

This would allow for multiple responsible parties per-product.  Note that I intentionally did not set a default value for either of the associated ID's to make sure that inserts are specified properly.

I believe that if this is implemented, it will become critical to have an admin_activity log that is there to log any changes made by administrators (responsible persons too) so that it would be possible to see what was done by whom and when making it possible to revert things at a later time.

Comment 1

12 years ago
why not assign a group?

Comment 2

12 years ago
I'm pretty sure this is a dupe. But I haven't time to check right now.
Whiteboard: DUPE ME

Comment 3

12 years ago
Instead of adding a new table with a list of user IDs, better is to have a group ID associated with products, and add power users to this group, as I did in bug 189627.

*** This bug has been marked as a duplicate of 189627 ***
Status: NEW → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → DUPLICATE
Whiteboard: DUPE ME
You need to log in before you can comment on or make changes to this bug.