Cross-platform Tamarin build system

VERIFIED FIXED

Status

Tamarin
Virtual Machine
VERIFIED FIXED
11 years ago
8 years ago

People

(Reporter: Benjamin Smedberg, Assigned: Benjamin Smedberg)

Tracking

Details

Attachments

(1 attachment)

(Assignee)

Description

11 years ago
We'd like to move away from the project files for MSVC/XCode (and linux makefiles) to a common build system. This is very first-draft and needs lots of work before it is ready, but I'd like to go ahead and land the first-cut files now. They build mmgc, avmplus, and the avm shell on mac-intel. The next steps include:

* a "cross" compile to mac-ppc
* universal binaries
* windows MSVC support
* linux support (I'm going to wait until the Linux code from Adobe lands before working on this)
(Assignee)

Comment 1

11 years ago
Created attachment 246965 [details] [diff] [review]
First-cut build system, rev. 1

This build system has the following requirements:

python 2.3+ (installed on mac by default)
GNU make 3.81+ (must be installed on mac! use darwinports "port install gmake")
Assignee: nobody → benjamin
Status: NEW → ASSIGNED
Attachment #246965 - Flags: review?(stejohns)

Comment 2

11 years ago
Comment on attachment 246965 [details] [diff] [review]
First-cut build system, rev. 1

Looks like a nice start, but mostly rubber-stamped approval for now. We should circle back later to ensure all compiler settings are suitable (or configurable); Tamarin currently builds with a very aggressive set of warnings and we'd like to keep it that way :-)
Attachment #246965 - Flags: review?(stejohns) → review+
(Assignee)

Comment 3

11 years ago
I'm using -Wall and disabling the following, so I think I reproduced what you wanted:

-Wno-reorder -Wno-switch -Wno-invalid-offsetof

We should probably fix the -Wno-reorder issues, but I was going to do that in a separate patch.

Comment 4

11 years ago
There is already another bug for "enable more warnings in Tamarin" (360829), which I am working on as snippets of time permit.
(Assignee)

Comment 5

11 years ago
Fixed on trunk. I'll file followup bugs about adding MSVC support and the other bits.
Status: ASSIGNED → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → FIXED

Comment 6

10 years ago
Transfer Bug from Core->Tamarin to Tamarin Product.
Component: Tamarin → Virtual Machine
Product: Core → Tamarin
Version: Trunk → unspecified

Updated

8 years ago
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.