Last Comment Bug 362297 - The xslt-param code doesn't initialize recycler
: The xslt-param code doesn't initialize recycler
Status: RESOLVED FIXED
: fixed1.8.1.1
Product: Core
Classification: Components
Component: XSLT (show other bugs)
: Trunk
: All All
: -- normal (vote)
: ---
Assigned To: Jonas Sicking (:sicking) No longer reading bugmail consistently
: Keith Visco
:
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2006-11-29 16:06 PST by Jonas Sicking (:sicking) No longer reading bugmail consistently
Modified: 2006-11-30 11:59 PST (History)
1 user (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Patch to fix (1.14 KB, patch)
2006-11-29 16:12 PST, Jonas Sicking (:sicking) No longer reading bugmail consistently
jonas: review+
jonas: superreview+
dveditz: approval1.8.1.1+
Details | Diff | Splinter Review

Description Jonas Sicking (:sicking) No longer reading bugmail consistently 2006-11-29 16:06:55 PST
The code that evaluates xslt-param XPath expressions doesn't initialize it's txExprResult recycler. This means that some expressions will crash with a null-pointer deref.
Comment 1 Jonas Sicking (:sicking) No longer reading bugmail consistently 2006-11-29 16:12:39 PST
Created attachment 247006 [details] [diff] [review]
Patch to fix

This was already reviewed by peterv as part of bug 361442
Comment 2 Jonas Sicking (:sicking) No longer reading bugmail consistently 2006-11-29 16:26:25 PST
This should be a very safe patch with extremely low risk and fixes a new feature in FF2 (xslt parameters)
Comment 3 Daniel Veditz [:dveditz] 2006-11-29 16:35:29 PST
Comment on attachment 247006 [details] [diff] [review]
Patch to fix

approved for 1.8 branch, a=dveditz
Comment 4 Jonas Sicking (:sicking) No longer reading bugmail consistently 2006-11-30 11:58:25 PST
Checked in to trunk too
Comment 5 Jonas Sicking (:sicking) No longer reading bugmail consistently 2006-11-30 11:59:00 PST
Removing dependency since I checked in the code here instead.

Note You need to log in before you can comment on or make changes to this bug.