Closed Bug 36231 Opened 20 years ago Closed 17 years ago

Launch mail preference ignored using either -installer or -profilemanager

Categories

(SeaMonkey :: MailNews: Message Display, defect, P3)

x86
Windows NT
defect

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 58523

People

(Reporter: selmer, Assigned: sspitzer)

References

Details

I have checked the preference to launch both browser and mail and can see this
preference setting when I Edit|Preferences.  However, when I luanch only the
browser window comes up.
Works for me using apr18 commercial m16 build on NT 4.0.
I used 2000-04-18-09 (M16) and it didn't work.
I launched netscape ("netscp6") with no arguments after having set the pref to
launch both browser and mail the previous session. Both mail and browser
launched using the same build you're using.

How are you launching seamonkey?
This may be a "first time only" kinda problem.  I used NetscapeSetup.exe to
install and then it ran itself from the installer but didn't bring up mail.  I'm
not sure if I used the icon the installer placed on the desktop once more and
had the same effect, but now when I use the icon it works as expected.  I think
this is probably restricted to the autolaunch the installer did.
I believe, then, the issue is when running with arguments like -installer (since
I believe that is what's run after installation) or -profilemanager.  

Changed summary to reflect the argument issue.
Summary: Startup ignores my launch mail preference → Startup ignores my launch mail preference (-installer, -profilemanager)
Readjusting summary.  The -ProfileManager flag is not used at install.
Summary: Startup ignores my launch mail preference (-installer, -profilemanager) → First startup ignores my launch mail preference (-installer)
Verified with 2000-04-19-09 build.  Only fails on initial launch from installer
or subsequent launch explicitly using the -installer flag.  Reassigning to Seth.
 Marking M17.
Assignee: selmer → sspitzer
Target Milestone: --- → M17
I put the -profilemanager in the summary because it also won't launch said set
preferences.  If you care about the first time installer, I thought you'd want
to possible address using -profilemanager, too.  They both wouldn't be used very
often...
Sorry, I misunderstood your previous comment.  Indeed, the -ProfileManager flag
also causes this behavior.  Adjusting the summary again :-)
Summary: First startup ignores my launch mail preference (-installer) → Launch mail preference ignored using either -installer or -profilemanager
I don't think that this needs to be M17. We have a lot of M18 and later bugs
that more poeple would run into and are more "harmful" bugs.  This bug can only
be encountered once or so and is really not that bad.
Mail Review hopes this is post-beta2, easy, polish work.  Marking M18.
Target Milestone: M17 → M18
clearing milestone, m17 and m18 are meaningless now.  these need to be triages
along with the rest.
Target Milestone: M18 → ---
also -P cause this bug.
*** Bug 107966 has been marked as a duplicate of this bug. ***
*** Bug 190768 has been marked as a duplicate of this bug. ***
This and bug 58523 are the same, but the other has a better summary and are
assigned, so I am duping this.

*** This bug has been marked as a duplicate of 58523 ***
Status: NEW → RESOLVED
Closed: 17 years ago
Resolution: --- → DUPLICATE
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.