Closed Bug 362348 Opened 13 years ago Closed 13 years ago

Crash [@ nsTableRowFrame::CollapseRowIfNecessary] on print preview with testcase, using display: table-footer-group; visibility: collapse;

Categories

(Core :: Layout: Tables, defect, critical)

x86
Windows XP
defect
Not set
critical

Tracking

()

VERIFIED FIXED

People

(Reporter: martijn.martijn, Assigned: bernd_mozilla)

References

Details

(Keywords: crash, regression, testcase)

Crash Data

Attachments

(3 files)

See upcoming testcase, which crashes current trunk (and reflow branch) builds when in print preview.

Talkback ID: TB26690522K
nsTableRowFrame::CollapseRowIfNecessary  [mozilla\layout\tables\nstablerowframe.cpp, line 1604]
nsTableRowGroupFrame::CollapseRowGroupIfNecessary  [mozilla\layout\tables\nstablerowgroupframe.cpp, line 873]
nsTableFrame::AdjustForCollapsingRowsCols  [mozilla\layout\tables\nstableframe.cpp, line 2421]
nsTableFrame::Reflow  [mozilla\layout\tables\nstableframe.cpp, line 2160]
nsContainerFrame::ReflowChild  [mozilla\layout\generic\nscontainerframe.cpp, line 742]
nsTableOuterFrame::OuterReflowChild  [mozilla\layout\tables\nstableouterframe.cpp, line 1302]
0x0296bb08

This seems like a regression, it doesn't crash on branch builds.
It doesn't crash with a 2006-03-01 build, it crashes with a 2006-03-05 build, I think it's a regression from bug 326551.
Attached file testcase
Assignee: nobody → bernd_mozilla
The testcase triggers the assert at http://lxr.mozilla.org/seamonkey/source/layout/tables/nsTableFrame.cpp#555

which describes exactly the problem we are running in.
Attached patch patchSplinter Review
Attachment #247159 - Flags: superreview?(roc)
Attachment #247159 - Flags: review?(roc)
Attachment #247159 - Flags: superreview?(roc)
Attachment #247159 - Flags: superreview+
Attachment #247159 - Flags: review?(roc)
Attachment #247159 - Flags: review+
Actually, make that an NS_STATIC_CAST
fixed,  testcase checked in into the table printing rtest dir.
Status: NEW → RESOLVED
Closed: 13 years ago
Flags: in-testsuite+
Resolution: --- → FIXED
Verified fixed, using:
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a1) Gecko/20061208
The testcase crashes Mozilla when closing print preview, but
that's because the reflow branch has landed and has been filed as bug 362210.
Status: RESOLVED → VERIFIED
Crash Signature: [@ nsTableRowFrame::CollapseRowIfNecessary]
You need to log in before you can comment on or make changes to this bug.