calendar events added from outlook meetings changing times on restart

RESOLVED DUPLICATE of bug 314339

Status

Calendar
General
--
major
RESOLVED DUPLICATE of bug 314339
11 years ago
11 years ago

People

(Reporter: dolo p. ragnoraks, Unassigned)

Tracking

Details

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X; en-US; rv:1.8.1) Gecko/20061010 Firefox/2.0
Build Identifier: Mozilla/5.0 (Macintosh; U; Intel Mac OS X; en-US; rv:1.8.1) Gecko/20061010 Firefox/2.0

When I accept a meeting and add it to my calendar from an outlook .ics file it appears to be correct when I go to the calendar. If I then close and re-open Thunderbird, all the times get pushed back. a 10:00 am meeting becomes 3:00 pm, an 11:30am meeting becomes 4:30pm. It appears that it's adding 5 to the 24 hour time, so 10:00 becomes 15:00, 11:30 becomes 16:30, etc. This happens on both mac and pc (OSX intel, and XP).

Reproducible: Always

Steps to Reproduce:
1. accept meeting from .ics attachment
2 [review]. close Thunderbird
3. restart Thunderbird

Actual Results:  
All meeting times added from .ics files have changed to +5 hours. This does not occur with dates not added from .ics files.

Comment 1

11 years ago
What is your timezone? I guess your timezone is UTC+5 and this is a duplicate of Bug 314339.
(Reporter)

Comment 2

11 years ago
My timezone is U.S. Eastern, same as the senders. Is there a timezone setting in Lightening separate from the computer's timezone? Here is a sample header from the .ics that has caused this (and yes it does appear to be the same as bug 314339).


BEGIN:VCALENDAR
VERSION:2.0
PRODID:-//Microsoft Corporation//Entourage Mac 11.0 MIMEDIR//EN
METHOD:REQUEST
BEGIN:VTIMEZONE
TZID:Eastern Time (US & Canada)
X-ENTOURAGE-TZID:4
X-ENTOURAGE-CFTIMEZONE:US/Eastern
BEGIN:STANDARD
TZNAME:Standard Time
RRULE:FREQ=YEARLY;INTERVAL=1;BYDAY=-1SU;BYMONTH=10
TZOFFSETFROM:-0400
TZOFFSETTO:-0500
DTSTART:20001029T020000
END:STANDARD
BEGIN:DAYLIGHT
TZNAME:Daylight Savings Time
RRULE:FREQ=YEARLY;INTERVAL=1;BYDAY=1SU;BYMONTH=4
TZOFFSETFROM:-0500
TZOFFSETTO:-0400
DTSTART:20010401T020000
END:DAYLIGHT
END:VTIMEZONE
BEGIN:VEVENT
UID:29DB62D4-80CA-11DB-A4EE-0017F2C50B76
X-ENTOURAGE_UUID:29DB62D4-80CA-11DB-A4EE-0017F2C50B76
DTSTAMP:20061130T232600Z
DTSTART;TZID="Eastern Time (US & Canada)":20061206T100000
DTEND;TZID="Eastern Time (US & Canada)":20061206T120000
LAST-MODIFIED:20061130T232600Z
(Reporter)

Comment 3

11 years ago
I have found that if after accepting a meeting I go to the Calendar and click on the time and change it, it then stays where I set it. I assume that strips the timezone attribute out of the data.
(Reporter)

Comment 4

11 years ago
I also see now that there is a timezone setting in the preferences/lightning tab. I set it to New York (where I am), but the time change still occurs on close and restart.

Comment 5

11 years ago
After restarting Thunderbird the 'non-mozilla' timezone information is lost as described in bug 314339. Resolving as duplicate.

I think opening and saving the events stores the event with the 'mozilla' timezone configured in Lightning preferences. Therefore the information is available after restart and the event is displayed fine.

*** This bug has been marked as a duplicate of 314339 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.