Customize Toolbar dialog is empty

VERIFIED FIXED

Status

Calendar
Sunbird Only
VERIFIED FIXED
12 years ago
10 years ago

People

(Reporter: ssitter, Assigned: philor)

Tracking

({regression})

Trunk
regression

Details

Attachments

(1 attachment, 1 obsolete attachment)

2.48 KB, patch
Matthew (lilmatt) Willis
: first-review+
Joey Minta
: second-review+
Details | Diff | Splinter Review
(Reporter)

Description

12 years ago
Cutomize Toolbar dialog is empty

Steps to Reproduce:
1. Start Sunbird
2. Select menu command 'View -> Toolbars -> Cutomize Toolbar ...'

Actual Results:
Dialog opens but only title bar is displayed. No dropdown menus, buttons or icons are displayed. No errors shown in console. Aborting the dialog displays following errors in console:

  Error: onAccept is not defined
  Source File: chrome://calendar/content/customizeToolbar.xul Line: 1
  Error: onUnload is not defined
  Source File: chrome://calendar/content/customizeToolbar.xul Line: 1

Regression range:
Works in Calendar/0.4a1 (2006120304)
Fails in Calendar/0.4a1 (2006120404)

This seems to be caused by the checkin for Bug 361246.
(Reporter)

Updated

12 years ago
Keywords: regression
Summary: Cutomize Toolbar dialog is empty → Customize Toolbar dialog is empty

Comment 1

12 years ago
philor, little help here?
(Assignee)

Comment 2

12 years ago
Oops, sorry, I completely forgot for a moment that you use the .js and not the .xul
Assignee: nobody → philringnalda
Blocks: 361246
(Reporter)

Comment 3

12 years ago
Created attachment 247456 [details] [diff] [review]
port toolkit changes
Attachment #247456 - Flags: first-review?(lilmatt)
Comment on attachment 247456 [details] [diff] [review]
port toolkit changes

This looks fine. r=lilmatt
Why do we use our own instead of toolkit's again?
Attachment #247456 - Flags: first-review?(lilmatt) → first-review+
because of bug 250793 (which is fixed now, so we should be able to use toolkit's version again)
(Reporter)

Comment 6

12 years ago
Looks as Bug 359656 was filed to make this possible.
(In reply to comment #6)
That bug appears to be Tb specific.

mvl:
Since you appear to understand this the most, could you come up with a patch to move Sb back to using toolkit's customizeToolbar.*?  I'm sure philor would appreciate one.
(Assignee)

Comment 8

12 years ago
Only item 1 is Tb-specific, item 2 is you: restore default set currently restores Fx's icons-large, not your full-small. Seriously, just hang on, I'm not that far from having you unforked. I'll split restore default from porting cancel, and once I land that it's just an #ifdef in your jar.mn. Days, tops.
(Assignee)

Comment 9

12 years ago
Er, your full-large - I keep getting thrown off by that "doesn't survive a change in size or default-set restore" iconsize="small" on the menu <toolbar>.
(Assignee)

Comment 10

12 years ago
Created attachment 247510 [details] [diff] [review]
with ifdefs

Just in case you feel like landing something you can cross-commit (and just to prove I wasn't just sitting on my hands this morning).
(Reporter)

Comment 11

12 years ago
Comment on attachment 247510 [details] [diff] [review]
with ifdefs

Requesting review on patch from Phil so that the regression can be fixed.
Attachment #247510 - Flags: second-review?(jminta)
Attachment #247510 - Flags: first-review?(lilmatt)
Comment on attachment 247510 [details] [diff] [review]
with ifdefs

r=lilmatt
Attachment #247510 - Flags: first-review?(lilmatt) → first-review+
(Reporter)

Updated

12 years ago
Attachment #247456 - Attachment is obsolete: true

Comment 13

12 years ago
Comment on attachment 247510 [details] [diff] [review]
with ifdefs

This is gonna be so nice once it's all finished. :-)
r2=jminta
Attachment #247510 - Flags: second-review?(jminta) → second-review+
Patch checked in on MOZILLA_1_8_BRANCH and trunk.

-> FIXED
Status: NEW → RESOLVED
Last Resolved: 12 years ago
Flags: blocking-calendar0.5+
OS: Windows 2000 → All
Hardware: PC → All
Resolution: --- → FIXED

Comment 15

12 years ago
verified with
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a1) Gecko/20061209 Calendar/0.4a1
Status: RESOLVED → VERIFIED

Updated

10 years ago
Flags: blocking-calendar0.5+
You need to log in before you can comment on or make changes to this bug.