santanderbanespa.com.br - Can not log in Santander/Banespa's netbanking, requires IE only

RESOLVED FIXED

Status

Tech Evangelism Graveyard
Portuguese
RESOLVED FIXED
11 years ago
3 years ago

People

(Reporter: Felipe Massia Pereira, Unassigned)

Tracking

Details

(URL)

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.1) Gecko/20061024 Iceweasel/2.0 (Debian-2.0+dfsg-1)
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.1) Gecko/20061024 Iceweasel/2.0 (Debian-2.0+dfsg-1)

Can not login. Tried three times. My account has been disabled. Same occurred to a friend.

Reproducible: Always

Steps to Reproduce:
1. You need an account AND login/password (I don't know how can I help, but I can't publish it here)
2. Enter account data in the initial page.
3. Then you need to fill login/password within the virtual keyboard and hit OK.

Actual Results:  
It gives "invalid password". If you do it three times, your login is disabled.

Expected Results:  
User logged in.

I'm using default theme and only an add-on: google sync. But my friend wasn't using any and still he had the same problem in this bug report.

I've been using Firefox 1.xx for a long time (more than a year) and this netbanking login was working fine.
(Reporter)

Comment 1

11 years ago
I have sent a message to the bank's client service telling them about the bug and asking for a "dummy account" which could be used for testing.
The problem with Banespa seems to be that Banespa uses SSL 2.0 which is disabled on Firefox 2.0 by default.
Look at this:
http://kb.mozillazine.org/SSL_is_disabled
(Reporter)

Comment 3

11 years ago
SSL is enabled, that's not the problem. Besides, it works with the big Mozilla.

According to a blog [1], bank says its site is certified with IE only. Shame.

I didn't receive answer to my request either.

I think it's time for we to have an independent web page with a table about banking sites compatibility with Mozilla Firefox.

[1] http://sergiohenrique.eng.br/wplog/?p=79

Comment 4

10 years ago
If the bank says it only works with IE, then this should be kicked over to TE and someone -- preferably several someones -- should have a chat with the bank about all the customers they're annoying (if not outright losing) with this behaviour.
Assignee: nobody → portuguese
Blocks: 124594
Component: General → Portuguese
OS: Linux → All
Product: Firefox → Tech Evangelism
QA Contact: general → portuguese
Hardware: PC → All
Summary: Can not log in Santander/Banespa's netbanking → santanderbanespa.com.br - Can not log in Santander/Banespa's netbanking, requires IE only
(Reporter)

Comment 5

10 years ago
Last time I checked, I could log in with FF 2.0. Unfortunately, I don't have a FF here to test.

Comment 6

10 years ago
Felipe, next time you get a chance, please check with Firefox 2 as well as a Minefield nightly.
(Reporter)

Comment 7

10 years ago
Firefox 2.0.0.13 for Windows (stable) is ok. I'm quite sure that it was working on Linux as well. I think you can close this bug.

Comment 8

10 years ago
Excellent. Thanks for the help. I'm going to assume the bank did something to fix this on their end.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → FIXED

Comment 9

10 years ago
I just tested it with Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.4; en-US; rv:1.9b4) Gecko/2008030317 Firefox/3.0b4. Worked for me too. 
Product: Tech Evangelism → Tech Evangelism Graveyard
You need to log in before you can comment on or make changes to this bug.