bugzilla.mozilla.org has resumed normal operation. Attachments prior to 2014 will be unavailable for a few days. This is tracked in Bug 1475801.
Please report any other irregularities here.

Failed to upgrade to HEAD

RESOLVED INVALID

Status

()

Bugzilla
Installation & Upgrading
RESOLVED INVALID
12 years ago
12 years ago

People

(Reporter: Johan Dahlin, Unassigned)

Tracking

Details

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.1) Gecko/20061010 Firefox/2.0
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.1) Gecko/20061010 Firefox/2.0

I upgrade from an old snapshot to HEAD:

Adding new column 'type' to the 'fielddefs' table...
Adding new column 'custom' to the 'fielddefs' table...
Adding new column 'enter_bug' to the 'fielddefs' table...
Renaming column 'fielddefs.fieldid' to 'fielddefs.id'...
DBD::mysql::db selectrow_hashref failed: Unknown column 'field_set' in 'field list' [for Statement "
            SELECT id,name,description,type,custom,mailhead,sortkey,obsolete,enter_bug,field_set,value_control_field FROM fielddefs
             WHERE name = ?"] at Bugzilla/Object.pm line 72
        Bugzilla::Object::_init('Bugzilla::Field', 'HASH(0x9d98984)') called at Bugzilla/Object.pm line 40
        Bugzilla::Object::new('Bugzilla::Field', 'HASH(0x9d98984)') called at Bugzilla/Field.pm line 710
        Bugzilla::Field::populate_field_definitions() called at ./checksetup.pl line 207

My fielddefs table looks like this;
mysql> describe fielddefs;
+-------------+--------------+------+-----+---------+----------------+
| Field       | Type         | Null | Key | Default | Extra          |
+-------------+--------------+------+-----+---------+----------------+
| id          | mediumint(9) |      | PRI | NULL    | auto_increment |
| name        | varchar(64)  |      | UNI |         |                |
| description | mediumtext   |      |     |         |                |
| mailhead    | tinyint(4)   |      |     | 0       |                |
| sortkey     | smallint(6)  |      | MUL | 0       |                |
| obsolete    | tinyint(4)   |      |     | 0       |                |
| type        | smallint(6)  |      |     | 0       |                |
| custom      | tinyint(4)   |      |     | 0       |                |
| enter_bug   | tinyint(4)   |      |     | 0       |                |
+-------------+--------------+------+-----+---------+----------------+

I also upgraded to MySQL 4.1.12 from 4.0.22, might be related.

Reproducible: Always

Comment 1

12 years ago
That's a problem with a local customization. The field_set column doesn't exist upstream.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.