mddepend.pl doesn't work under beos

VERIFIED FIXED

Status

SeaMonkey
Build Config
P3
major
VERIFIED FIXED
18 years ago
13 years ago

People

(Reporter: justin morey, Assigned: cls)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

18 years ago
on the beos, unlike unix, when cpp generates .cpp/.h dependencies, a space is
placed between the object file name and the colon which separates it from the
list of files it depends on.  for example: say we have a file stuff.cpp.  when
built under the beos, its dep file (.deps/stuff.pp) will begin "stuff.o :
stuff.cpp junk.h words.h".  the same file, built under unix, will begin
"stuff.o: stuff.cpp..." (no space between .o and the colon).

this extra space breaks mddepend.pl (it thinks the trailing space is part of the
object file name), which, in turn, generally causes incremental builds to fail.
(Reporter)

Comment 1

18 years ago
Created attachment 7726 [details] [diff] [review]
patch to fix bug
(Reporter)

Updated

18 years ago
Keywords: patch
(Assignee)

Updated

18 years ago
Status: UNCONFIRMED → ASSIGNED
Ever confirmed: true
(Assignee)

Comment 2

18 years ago
*** Bug 36506 has been marked as a duplicate of this bug. ***
(Assignee)

Comment 3

18 years ago
Patch has been checked in.
Status: ASSIGNED → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → FIXED
(Reporter)

Comment 4

18 years ago
problem fixed - thanks!
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.