Last Comment Bug 363089 - Remove nsIDOMEventReceiver
: Remove nsIDOMEventReceiver
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: DOM: Events (show other bugs)
: Trunk
: All All
: -- normal (vote)
: ---
Assigned To: Olli Pettay [:smaug]
: Hixie (not reading bugmail)
: Andrew Overholt [:overholt]
Mentors:
Depends on: 363067 378102 408238
Blocks:
  Show dependency treegraph
 
Reported: 2006-12-07 10:18 PST by Olli Pettay [:smaug]
Modified: 2007-12-13 12:33 PST (History)
9 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
v1 (269.45 KB, patch)
2007-04-20 09:53 PDT, Olli Pettay [:smaug]
jst: review+
jst: superreview+
Details | Diff | Splinter Review
checked in (279.83 KB, patch)
2007-05-14 04:34 PDT, Olli Pettay [:smaug]
no flags Details | Diff | Splinter Review
leftovers (18.84 KB, patch)
2007-05-14 15:10 PDT, Olli Pettay [:smaug]
jst: review+
jst: superreview+
Details | Diff | Splinter Review

Description Olli Pettay [:smaug] 2006-12-07 10:18:26 PST
After bug 363067, nsIDOMEventReceiver could be merged to nsPIDOMEventTarget.
Comment 1 Olli Pettay [:smaug] 2006-12-09 10:14:11 PST
Actually, nsIDOMEventReceiver can be just removed and use nsIEventListenerManager when really needed.
Comment 2 Olli Pettay [:smaug] 2006-12-10 05:05:56 PST
WIP patch containing also bug 363067 is here http://www.cs.helsinki.fi/u/pettay/moztests/events/remove_nsidomeventreceiver.diff
Comment 3 Olli Pettay [:smaug] 2006-12-11 02:16:26 PST
http://www.cs.helsinki.fi/u/pettay/moztests/events/remove_nsidomeventreceiver.diff
should remove now all uses of nsIDOMEventReceiver.
And it even compiles (ff, tb, sm) :)

Waiting for bug 363067.
Comment 4 Olli Pettay [:smaug] 2007-04-20 09:53:06 PDT
Created attachment 262273 [details] [diff] [review]
v1
Comment 5 Johnny Stenback (:jst, jst@mozilla.com) 2007-05-09 17:11:45 PDT
Comment on attachment 262273 [details] [diff] [review]
v1

- In content/xbl/public/nsIXBLService.h:

-  NS_IMETHOD AttachGlobalKeyHandler(nsIDOMEventReceiver* aElement)=0;
+  NS_IMETHOD AttachGlobalKeyHandler(nsPIDOMEventTarget* aTarget)=0;

Since you're changing this "interface", you should bump the IID here (even if it's not in IDL). Same for nsPIDOMEventTarget.

- In embedding/browser/gtk/src/EmbedPrivate.h:

   EmbedContentListener          *mContentListener;
   nsCOMPtr<nsISupports>          mContentListenerGuard;
   EmbedEventListener            *mEventListener;
   nsCOMPtr<nsISupports>          mEventListenerGuard;
 
   nsCOMPtr<nsIWebNavigation>     mNavigation;
   nsCOMPtr<nsISHistory>          mSessionHistory;
 
-  // our event receiver
-  nsCOMPtr<nsIDOMEventReceiver>  mEventReceiver;
+  nsCOMPtr<nsPIDOMEventTarget>  mEventTarget;

Add a space to make member names line up again.

r+sr=jst with that.
Comment 6 Olli Pettay [:smaug] 2007-05-11 03:14:04 PDT
I'll check this in during next weekend, when there aren't too many
other check-ins.
Comment 7 Olli Pettay [:smaug] 2007-05-11 04:21:50 PDT
bah, I just checked this in. Hoping not to see to much red in tboxes.
Comment 8 Olli Pettay [:smaug] 2007-05-11 06:56:12 PDT
backed out. some chrome and mochitests failed and couldn't immediately see where to problem is.
Comment 9 Olli Pettay [:smaug] 2007-05-14 04:34:33 PDT
Created attachment 264731 [details] [diff] [review]
checked in
Comment 10 Olli Pettay [:smaug] 2007-05-14 06:06:24 PDT
nsIDOMEventTarget occurs still few times in the tree, for example in
some comments. I'll post a small patch to remove those.
Comment 11 Olli Pettay [:smaug] 2007-05-14 15:10:42 PDT
Created attachment 264801 [details] [diff] [review]
leftovers

Things which aren't usually (or ever) compiled.
The strange looking part is nsWindowRoot, but those macros don't
actually use the second parameter currently.
Comment 12 Johnny Stenback (:jst, jst@mozilla.com) 2007-05-14 16:56:29 PDT
Comment on attachment 264801 [details] [diff] [review]
leftovers

r+sr=jst

Note You need to log in before you can comment on or make changes to this bug.