There are additional backgrounds on the http://www.mtv.de/kino/index.php

RESOLVED DUPLICATE of bug 363329

Status

()

RESOLVED DUPLICATE of bug 363329
12 years ago
12 years ago

People

(Reporter: romaxa, Unassigned)

Tracking

({qawanted, regression})

Trunk
x86
Linux
qawanted, regression
Points:
---
Dependency tree / graph
Bug Flags:
in-testsuite -

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(4 attachments)

(Reporter)

Description

12 years ago
After landing of reflow_branch patch appears next collisions on page

http://www.mtv.de/kino/index.php

STEPS LEADING TO PROBLEM: 
1. Go to the http://www.mtv.de/kino/index.php
2. scroll page to the middle


EXPECTED OUTCOME:
Page should be displayed properly.

ACTUAL OUTCOME:
There are additional green backgrounds on the right side of the page. They are
displayed between the middle part and the right part of the page. 

See screenshots in attachments
(Reporter)

Comment 1

12 years ago
Blocks: 300030
Keywords: regression
Summary: [Regression] BUG 300030 There are additional backgrounds on the http://www.mtv.de/kino/index.php → There are additional backgrounds on the http://www.mtv.de/kino/index.php
(Reporter)

Comment 2

12 years ago
A <table width="424"> is 424px wide in a non-reflow-branch build and 456px wide in a reflow branch one.  Testcase would help.
Keywords: qawanted
Component: Layout → Layout: Tables
QA Contact: layout → layout.tables
Posted file testcase?
I'm not sure how useful this is, I reduced this from the MTV.com page. It does show a difference between trunk before reflow branch landing and after. In the post-reflow-landing build, the table is 588px wide, in my pre-reflow-landing build (trunk 2006-12-04) the table is 310px wide.
Filed bug 363150 on that testcase; the patch there fixes it but not this bug or bug 363144... so once that lands we can try reducing again.
Posted file another testcase
I applied the patch for bug 363150 and tried to reduce this testcase again. As with the previous testcase, I'm not sure that this is the only cause of the layout problem on that site, but it shows more differences between builds from before and after the reflow branch landing.

1) getComputedStyle for the tables is broken and always returns the width of the viewport (more than likely a seperate bug)
2) The first table is a few pixels smaller in a pre-reflow branch landing build (two distinct background "sections" vs. 3)
Yeah, getComputedStyle is a separate bug.  Get it filed and cc me?  I can try to fix it tonight, but I have a plane to catch right now...
I filed bug 363183 for the getComputedStyle part.
(Reporter)

Comment 9

12 years ago
Bug 363150 fixed, but all other bugs related to mtv.de still reproducable..

Also table "KINO CHARTS" in URL page, also looks very bad.


*** This bug has been marked as a duplicate of 363329 ***
Status: NEW → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → DUPLICATE
Bug 363329 fixes the page, although both testcases are still broken.  However, separate bugs have been filed on both of them, so that seems ok.
This seems to be covered by other bugs/tests.
Flags: in-testsuite-
You need to log in before you can comment on or make changes to this bug.