Session Restore will not work if the "Warn on closing a window with mutiple tabs open," is unchecked

RESOLVED WORKSFORME

Status

()

Firefox
General
RESOLVED WORKSFORME
12 years ago
12 years ago

People

(Reporter: citrus4965, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1) Gecko/20061010 Firefox/2.0
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1) Gecko/20061010 Firefox/2.0

While trying out new features in FF 2, I couldn't get the "Session Restore" feature to work. After much trial and error, I found that by I could toggle this feature by checking and unchecking the Tools/Options/Tabbed Browsing/Features/"Warn on closing a window with multiple tabs open" option.

Reproducible: Always

Steps to Reproduce:
1. uncheck the Tools/Options/Tabbed Browsing/Features/"Warn on closing a window with multiple tabs open" option.
2. On the PC do a Ctrl/Alt/Delete to bring up Windows Task Manager, select Firefox and hit the "End Task" button. This will crash off Firefox.
3. Bring Firefox back up and you will not get the Restore Session User Interface
4. Repeat the whole process with the Tools/Options/Tabbed Browsing/Features/"Warn on closing a window with multiple tabs open" option, checked (on) and the Session Restore will work fine.




Expected Results:  
The Session Restore should not be affected by the state of the "Warn on closing a window with multiple tabs open" option.
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1) Gecko/20061010 Firefox/2.0
Can't reproduce this. Did you also test this in Firefox's safe-mode, with a new profile or with a re-installation in a new clean folder?
(Reporter)

Comment 2

12 years ago
Did you also test this in Firefox's safe-mode, with a new
profile or with a re-installation in a new clean folder? - Yes, I tested this with a new profile and also in the safe mode with all blocks checked....... same results. I will test this on my wife's PC. She is currently running FF 1.?? I will uninstall it and load up 2.0. This should eliminate anything odd with my PC.   
I will let you know how I make out. 
(Reporter)

Comment 3

12 years ago
All the testing up to this point was on my PC. I decided to try and replicate it on my wife's PC.
I un-installed my wife's FF1.?? and removed the old profile folders, so I have a clean different machine. I downloaded FF2.0 from the Mozilla website. I set up the same test scenario...... I got the same results. NO Session Restore box when I Started up FF2.0 after crashing it off, when the "Warn on closing a window with multiple tabs open" was not checked on the "Tabs" option. With "Warn on closing a window with multiple tabs open" checked, and I crashed off, I got the "Session Restore" box when I started up FF2.0, as I should. To simulate a crash, I use the Windows Task manager, select the FF2.0 application and hit the "end task" button.

Comment 4

12 years ago
When trying to reproduce this issue, make sure that you wait for at least 10 seconds after the browser window appears before killing Firefox. During those first 10 seconds, no session related information is written to disk and Firefox won't thus recognize the crash nor will it have anything to restore anyway.
(Reporter)

Comment 5

12 years ago
Folks, I am pretty sure I found the problem and it is me... :-) (sort of) It was how I was "crashing off" FF2. When I went to the Windows Task Manager to simulate a crash, I went to the Applications tab and selected FF2. If you do this you will see what I called the failure, because when FF2 comes back it will not give you the Session Restore box........ (Based on your not being able to replicate this problem, started me looking at my test process)..........

Instead of the Applications tab on the Windows Task Manager, I went to the Processes tab and selected firefox.exe. No failures..... FF2 worked as designed.

So I conclude......... "Ending Task" from Windows Task Manager, Applications tab, lets FF2 down easy, if you don't have the "Warn on closing a window with multiple tabs open," option checked. (the same as Xing off I guess) So FF2 see no reason to go into Session Restore.   "Ending Task" from Windows Task Manager, Process tab, absolutely crashes it off. (It even gives you a warning box, whereas the Applications tab does not give you the warning.) So FF2's Session Restore kicks in as designed. 

As far as being able to toggle the failure based on the state of the "Warn on closing a window with multiple tabs open" box.......... I speculate that, when the box is checked, and you hit "End Task," in the Applications tab of the Windows task Manager, FF2 gives you the warning that you are closing with multiple tabs, if you ignore this warning, (and I did in the original testing) Windows at this point overrides that warning and closes FF2. FF2, because of the override of the warning box, sees this as a crash and will go into Session Restore on the next activation. (Whew)

Sorry about that folks, I reported it in good faith. Thanks for your help.
Don Devine

Updated

12 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.