Closed Bug 363402 Opened 14 years ago Closed 13 years ago

[reflow branch] Layout issue at wikipedia

Categories

(Core :: Layout: Tables, defect, P1)

defect

Tracking

()

RESOLVED FIXED
mozilla1.9

People

(Reporter: BijuMailList, Assigned: dbaron)

References

()

Details

(Keywords: regression, top100, Whiteboard: [table captions])

Attachments

(5 files, 1 obsolete file)

I dont know whether this is a bug 
go to 
http://en.wikipedia.org/wiki/South_Asian_Association_for_Regional_Cooperation
see the Info box on right top
"South Asian Association of Regional Cooperation" is not broken into two lines.

please feel free to change heading.
Attached image Firefox.png
Attached image IE.png
Attached file SAARC.htm
Regression between 1.9a1_2006120714 and 1.9a1_2006120722 which points to Bug 300030.
Summary: Layout issue at wikipedia → [reflow branch] Layout issue at wikipedia
(In reply to comment #4)
> Regression between 1.9a1_2006120714 and 1.9a1_2006120722 
> which points to Bug 300030.
so CCing  David Baron 

I think this is the same issue as bug 363248. The table caption is too wide.
Depends on: 363248
Keywords: regression, top100
OS: Windows XP → All
Whiteboard: [table captions]
The same problem occures on the German wikipedia article "Eibe" (engl. "Taxus").
Here the link: http://de.wikipedia.org/wiki/Eiben

I was able to reproduce the error on the following platforms:
Windows 2000 SP 4 - Firefox 1.5
Windows 2000 SP 4 - Firefox 2.0.0.4
Windows XP SP 2 - Firefox 2.0.0.4
Fedora Core 3 - Firefox 1.5
Sandro, this bug is for a regression from known check-in exclusive to the Gecko 1.9 trunk (i.e. the core of what will be Firefox 3.0). Please file a new bug if you're having problems with Firefox 1.5/2.0 as it's most likely unrelated to this bug.
Oh, I'm deeply sorry , I posted it on the wrong bugreport O.o Please ignore my last comment.
Not completely fixed by bug 363248, though.  The intrinsic width of the thing with the table and caption in it is still too wide, it seems.
Flags: blocking1.9?
And it's still a problem in my testcases (attachment 305673 [details] and attachment 305674 [details]) that I used there -- I just didn't notice it.  In particular, under "floating table", for the "top" and "bottom" caption-side cases, see the cases with "caption with a decent sized pref width".
Assignee: nobody → dbaron
Attached patch patch (obsolete) — Splinter Review
We need to do this computation because of bug 349457, essentially due to the weirdness of being a block that's not the containing block for its children's percentage widths.

But what we do really does need to match nsTableOuterFrame::Reflow; this makes it do so.
Attachment #306156 - Flags: superreview?(roc)
Attachment #306156 - Flags: review?(roc)
Attachment #306156 - Attachment is obsolete: true
Attachment #306156 - Flags: superreview?(roc)
Attachment #306156 - Flags: review?(roc)
Attached patch patchSplinter Review
Attachment #306158 - Flags: superreview?(roc)
Attachment #306158 - Flags: review?(roc)
Attachment #306158 - Flags: superreview?(roc)
Attachment #306158 - Flags: superreview+
Attachment #306158 - Flags: review?(roc)
Attachment #306158 - Flags: review+
Comment on attachment 306158 [details] [diff] [review]
patch

This was supposed to be fixed by the changes I landed yesterday, but I missed this bit.

I'd be ok with landing this after the final beta, but I'd prefer to have it in.
Attachment #306158 - Flags: approval1.9b4?
Flags: tracking1.9? → blocking1.9?
Comment on attachment 306158 [details] [diff] [review]
patch

a1.9b4=beltzner
Attachment #306158 - Flags: approval1.9b4?
Attachment #306158 - Flags: approval1.9b4+
Attachment #306158 - Flags: approval1.9+
Checked in to trunk 2008-02-28 09:55 -0800.
Assignee: dbaron → nobody
Component: Layout → Layout: Tables
Flags: in-testsuite+
QA Contact: layout → layout.tables
Hardware: PC → All
Target Milestone: --- → mozilla1.9beta4
Flags: blocking1.9? → blocking1.9+
Priority: -- → P1
Target Milestone: mozilla1.9beta4 → mozilla1.9
Assignee: nobody → dbaron
Status: NEW → RESOLVED
Closed: 13 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.