If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Toolbar control (toolbar collapse widget) missing in Cocoafox

RESOLVED FIXED in mozilla1.9alpha5

Status

()

Core
Widget: Cocoa
RESOLVED FIXED
11 years ago
10 years ago

People

(Reporter: philor, Assigned: cbarrett)

Tracking

({regression})

Trunk
mozilla1.9alpha5
x86
Mac OS X
regression
Points:
---
Bug Flags:
blocking1.9 +
wanted1.9 +

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

11 years ago
There's no pill/button in the window title bar that you can click to hide the toolbars in Cocoa Firefox.

Comment 1

11 years ago
I don't see anything in the Cocoa API that might allow us to do this. It looks like up until 10.4 that button's appearance was automatic, and in 10.4 there is an API but it only affects the window if your window has a native toolbar.

Updated

11 years ago
Assignee: joshmoz → nobody
(Reporter)

Updated

11 years ago
Flags: blocking1.9?
Keywords: regression
I don't see it in Cocoafoxen on 10.3.9, either, though.
Flags: blocking1.9? → blocking1.9-
Whiteboard: [wanted-1.9]
(Assignee)

Comment 3

11 years ago
I have a patch in my tree I need to clean up that fixes this.

It uses two private methods on NSWindow that don't look terribly invasive to override.

(BOOL)_hasToolbar;
(void)_toolbarPillButtonClicked:(id)sender;

I found them while poking around with F-Script on something unrelated.
Flags: blocking1.9- → blocking1.9?
(Assignee)

Comment 4

11 years ago
Created attachment 264200 [details] [diff] [review]
fix v1.0

Here is the previously mentioned patch.
Assignee: nobody → cbarrett
Status: NEW → ASSIGNED
Attachment #264200 - Flags: review?(joshmoz)

Updated

11 years ago
Flags: blocking1.9? → blocking1.9+

Updated

11 years ago
Target Milestone: --- → mozilla1.9alpha5
(Assignee)

Updated

11 years ago
Status: ASSIGNED → NEW
(Assignee)

Comment 5

11 years ago
Comment on attachment 264200 [details] [diff] [review]
fix v1.0

mento, can you review this instead, since Josh seems overloaded on other things?
Attachment #264200 - Flags: review?(joshmoz) → review?(mark)

Comment 6

11 years ago
Comment on attachment 264200 [details] [diff] [review]
fix v1.0

Have you tried this out on a Lep seed too?
Attachment #264200 - Flags: review?(mark) → review+

Updated

11 years ago
Attachment #264200 - Flags: review+
Comment on attachment 264200 [details] [diff] [review]
fix v1.0

sr=mconnor, please get this landed ASAP
Attachment #264200 - Flags: superreview+
(Reporter)

Comment 8

11 years ago
widget/src/cocoa/nsCocoaWindow.h 1.33
widget/src/cocoa/nsCocoaWindow.mm 1.89

Having to check in fixes for my own bugs sure beats having to fix my own bugs :)
Status: NEW → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → FIXED
Flags: wanted1.9+
Whiteboard: [wanted-1.9]
You need to log in before you can comment on or make changes to this bug.