session restore default preferences missing from firefox.js

RESOLVED DUPLICATE of bug 340895

Status

()

Firefox
Tabbed Browser
RESOLVED DUPLICATE of bug 340895
12 years ago
12 years ago

People

(Reporter: dveditz, Assigned: dietrich)

Tracking

2.0 Branch
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

12 years ago
Convention says preferences we use should have default values in one of the pref.js files; session restore needs to add its default prefs to firefox.js

Without default prefs these become hidden values that don't appear in about:config, making it much harder for customizers, documentors, and tech support to figure out when people need help.

  browser.sessionstore.enabled
  browser.sessionstore.interval
  browser.sessionstore.max_tabs_undo
  browser.sessionstore.postdata
  browser.sessionstore.privacy_level

resume_from_crash and resume_session_once look internal and possibly don't need prefs. restore_prompt_uri we definitely don't want a default value for.
(Reporter)

Updated

12 years ago
Flags: blocking1.8.1.2?
OS: Windows XP → All
Hardware: PC → All
(Assignee)

Comment 1

12 years ago

*** This bug has been marked as a duplicate of 340895 ***
Status: NEW → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → DUPLICATE

Updated

12 years ago
Flags: blocking1.8.1.2?
You need to log in before you can comment on or make changes to this bug.