dropdown selects garble arrow+browser area

VERIFIED FIXED in M16

Status

()

Core
Layout: Form Controls
P3
normal
VERIFIED FIXED
18 years ago
18 years ago

People

(Reporter: R.K.Aa., Assigned: rods (gone))

Tracking

Trunk
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

18 years ago
Build ID 2000-041908 M16 Linux

After the fix for bug 30091 was in, the behaviour of dropdown boxes changed a
little. Sample URL bugzilla.mozilla.org/query.cgi

The mispainting consists of various ascii signs being written on dropdownbox
arrow button, and to the right of it, once a select is made.
The signs that are "mispainted with" depends on what you wrote in the
searchfield, but it's not 100% consistant from time to time.
In addition, the mispainting doesn't occure for all the selects, just some.

Attaching screenshot.
(Reporter)

Comment 1

18 years ago
Created attachment 7750 [details]
garble

Comment 2

18 years ago
Reassigning to Rod
Assignee: troy → rods
(Reporter)

Comment 3

18 years ago
i don't see this anymore. build 2000-042609 M16
(Assignee)

Comment 4

18 years ago
I guess I will mark it works for me.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → WORKSFORME

Comment 5

18 years ago
*** Bug 38394 has been marked as a duplicate of this bug. ***

Comment 6

18 years ago
Isn't this bug a dup of a much older one?

In any case, reopening in light of bug 38394, which I was able to reproduce.  
See that bug for some more details, adding URL.
Status: RESOLVED → UNCONFIRMED
Component: Layout → HTML Form Controls
Resolution: WORKSFORME → ---

Comment 7

18 years ago
changing QA, confirming
Status: UNCONFIRMED → NEW
Ever confirmed: true
QA Contact: petersen → ckritzer
(Reporter)

Comment 8

18 years ago
the mispainting mentioned in 38394 is somewhat visible on linux too, but not as
clear: it seems to be located lower on the button, so only the top of something
displays.
Different from when this bug was originally submitted, the mispainting
is now only ON the button, no longer extending out on the webpage to the right
of it. A click on the button seems to refresh it and the "characters" go away.

Comment 9

18 years ago
I don't see that.  Some things still do carry onto the content area -- for 
example, choosing the "HP" option under the "Platform" dropdown box in the URL 
above will still cause garbage ASCII to extend into the area surrounding the 
box.

Furthermore, in the aforementioned example, a mere click on the button doesn't 
cause the characters to disappear, as you said.  I'm seeing this in 2000050608 
win98.
(Assignee)

Comment 10

18 years ago
This might be a clipping problem or it could be related to 36558. 36558 changes 
how the display area is created, what frames are used and how they are resized. 
Once that is checked in we should recheck this on Linux.
Status: NEW → ASSIGNED
Depends on: 36558
Target Milestone: --- → M16
(Assignee)

Comment 11

18 years ago
This should be fixed, can anybody reproduce it?
(Reporter)

Comment 12

18 years ago
can only speak for linux, where i don't see the problem now. (2000-050820)

Comment 13

18 years ago
I did see this in a build yesterday or the day before, but not today's build.
( 2000050920 )

-WD
(Assignee)

Comment 14

18 years ago
I will close this out because we are getting close to the tree closing, if you 
see it, open this back up.
Status: ASSIGNED → RESOLVED
Last Resolved: 18 years ago18 years ago
Resolution: --- → FIXED

Comment 15

18 years ago
vrfy fixed, no longer seeing in 2000052508
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.