No twisty after drag and drop into new/empty folder.

RESOLVED WORKSFORME

Status

SeaMonkey
Bookmarks & History
RESOLVED WORKSFORME
12 years ago
6 years ago

People

(Reporter: stephend, Unassigned)

Tracking

Trunk
x86
Windows XP

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [2012 Fall Equinox])

(Reporter)

Description

12 years ago
While the bug that one can't paste a bookmark into a new--and therefore empty--folder is known (see bug 230563), a subsequent drag and drop of that bookmark works, yet the folder's twisty isn't updated.  (Tree isn't getting notified of its new content, somehow.)

Steps to Reproduce:

1. Create a folder in the Manage Bookmarks dialog.
2. Select any bookmark, and use Cut.
3. Paste into the folder from step one.
4. Now, drag and drop into that same folder.

Expected Results:

Twisty

Actual Results:

No twisty.

Comment 1

12 years ago
I don't know if this assertion is relevant:

###!!! ASSERTION: couldn't find row: 'iter != mRows.Last()', file c:/trunk/mozilla/content/xul/templates/src/nsXULTreeBuilder.cpp, line 1135

Note that as a workaround you can highlight the folder and press right-arrow before pasting and then the bookmark will paste in to the folder and as a bonus the twisty will appear too ;-)
[Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.9a5pre) Gecko/20070428 SeaMonkey/1.5a] (nightly) (W2Ksp4)

1) The twisty does not appear when D&Ding the first bookmark.
2) The twisty does not disappear when deleting the last bookmark.

Comment 3

9 years ago
Confirming for 2.0.1pre

Comment 4

6 years ago
Can't reproduce on current nightly, closing
User agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:18.0) Gecko/18.0 Firefox/18.0 SeaMonkey/2.15a1
Build identifier: 20120921003032
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → WORKSFORME
Whiteboard: [2012 Fall Equinox]
You need to log in before you can comment on or make changes to this bug.