Closed Bug 364036 Opened 14 years ago Closed 14 years ago

When saving a Web Page completely, graphics in CSS files are ignored

Categories

(Firefox :: General, defect)

x86
Windows 2000
defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 115107

People

(Reporter: c.bouvier, Unassigned)

References

()

Details

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.8.1) Gecko/20061010 Firefox/2.0
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.8.1) Gecko/20061010 Firefox/2.0

CSS allows the specification of background images or images that are shown before a certain object. Examples:

body {
  background: url(./file.jpg) repeat-y;
}

or metaclasses like "before":

p:before {
  content: url(./file.png);
}

The first example tells the browser to repeat the given background image vertically. The second example means that inside a <p> element the image file.png should be shown first. Firefox of course does interpret this correctly, but when saving a web page via "File => Save Page as... => Web page, complete", these files are ignored and not downloaded to the location provided. When opening the previously saved file, the page looks weird because all images defined that way are completely ignored.

Reproducible: Always

Steps to Reproduce:
1. Go to a page using a CSS file with the "before" metaclass defining an image or specifying background images with the "background:" attribute.
2. File => Save as... => Web page, complete
3. Open previously saved file. 

Actual Results:  
The images that the CSS-file refers to are not loaded and therefore such a page looks quite weird without these images.

Expected Results:  
Actually I expected Firefox to save these images to the given harddrive location as well. This cannot be hard to implement as Firefox in fact does load the files when the html/css files are remotely opened via an http request.

*** This bug has been marked as a duplicate of 115107 ***
Status: UNCONFIRMED → RESOLVED
Closed: 14 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.