Winhooks commandline options won't work in suiterunner

RESOLVED FIXED in seamonkey2.0a1

Status

SeaMonkey
General
RESOLVED FIXED
12 years ago
7 months ago

People

(Reporter: standard8, Assigned: standard8)

Tracking

(Blocks: 2 bugs)

Trunk
seamonkey2.0a1
x86
All
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(3 attachments)

(Assignee)

Description

12 years ago
Winhooks (under xpfe/components/winhooks) appears to implement three command line arguments based on the old xpfe commandline handler:

-setDefaultMail
-unsetDefaultMail
-setDefaultBrowser

I'm guessing we probably don't have equivalents elsewhere but they need testing at least.
(Assignee)

Updated

11 years ago
Depends on: 380347
Since comment #0, more than a year has gone by. Should this bug fall into oblivion?
(Assignee)

Comment 2

10 years ago
(In reply to comment #1)
> Since comment #0, more than a year has gone by. Should this bug fall into
> oblivion?
> 
No, please stop making useless comments, see the dependent bug, that needs to be completed first (at least on Windows).
(Assignee)

Comment 3

10 years ago
Created attachment 336828 [details] [diff] [review]
[checked in] Drop winhooks (comm-central changes)

Now Frank has the UI in place, its time for this to die. Here's the comm-central changes, including one hook change for the setting of the desktop background (note there is other code in that file which means it is only enabled on windows).

I think the pref-winhooks* code is no longer used, but I'll let someone else deal with that.
Assignee: general → bugzilla
Status: NEW → ASSIGNED
Attachment #336828 - Flags: superreview?(neil)
Attachment #336828 - Flags: review?(neil)
(Assignee)

Comment 4

10 years ago
Created attachment 336829 [details] [diff] [review]
[checked in] Drop winhooks (mozilla-central changes)

Here's the mozilla-central changes. Dropping winhooks means we can get rid of that nasty jar.mn in xpfe/components and put it in the autocomplete directory instead making it all much simpler.
Attachment #336829 - Flags: superreview?(neil)
Attachment #336829 - Flags: review?(neil)

Comment 5

10 years ago
(In reply to comment #3)
> (note there is other code in that file which means it is only enabled on windows)
... which is now the wrong test, of course ...

Updated

10 years ago
Attachment #336829 - Flags: superreview?(neil)
Attachment #336829 - Flags: superreview+
Attachment #336829 - Flags: review?(neil)
Attachment #336829 - Flags: review+

Comment 6

10 years ago
Comment on attachment 336828 [details] [diff] [review]
[checked in] Drop winhooks (comm-central changes)

Is there a bug on fixing the wallpaper enabling code to check for the shell service instead?
Attachment #336828 - Flags: superreview?(neil)
Attachment #336828 - Flags: superreview+
Attachment #336828 - Flags: review?(neil)
Attachment #336828 - Flags: review+

Comment 7

10 years ago
(In reply to comment #3)
> I think the pref-winhooks* code is no longer used
Agreed.

> but I'll let someone else deal with that.
Does that include filing the bug? ;-)

Comment 8

10 years ago
Comment on attachment 336829 [details] [diff] [review]
[checked in] Drop winhooks (mozilla-central changes)

>diff --git a/xpfe/components/build/appcomps.pkg b/xpfe/components/build/appcomps.pkg

.pkg files were born dead and have never come to life, so it's usually not worth updating them.

Comment 9

10 years ago
(In reply to comment #3)
> I think the pref-winhooks* code is no longer used, but I'll let someone else
> deal with that.

Should be easy to clean up though...

Comment 10

10 years ago
Created attachment 336865 [details] [diff] [review]
[checked in] kill pref-winhooks

This additional patch kills pref-winhooks. I have no idea how it was included in the prefwindow, I find no reference to it.
Attachment #336865 - Flags: superreview?(neil)
Attachment #336865 - Flags: review?(bugzilla)

Comment 11

10 years ago
Comment on attachment 336865 [details] [diff] [review]
[checked in] kill pref-winhooks

(In reply to comment #10)
>I have no idea how it was included in the prefwindow, I find no reference to it.
Mnyromyr removed platformPrefOverlay.xul in bug 394522.

>-  "chrome://communicator/content/pref/pref-winhooks.xul": "advanced_pref_system",
You don't really need to change this, it won't break the rest of the legacy prefwindow and it will get removed along with it anyway.
Attachment #336865 - Flags: superreview?(neil) → superreview+
(Assignee)

Comment 12

10 years ago
Comment on attachment 336828 [details] [diff] [review]
[checked in] Drop winhooks (comm-central changes)

Checked in, changeset id 258:4e64b9298751
Attachment #336828 - Attachment description: Drop winhooks (comm-central changes) → [checked in] Drop winhooks (comm-central changes)
(Assignee)

Comment 13

10 years ago
Comment on attachment 336829 [details] [diff] [review]
[checked in] Drop winhooks (mozilla-central changes)

Checked in, changeset id: 18800:2e8e583fc354
Attachment #336829 - Attachment description: Drop winhooks (mozilla-central changes) → [checked in] Drop winhooks (mozilla-central changes)
(Assignee)

Updated

10 years ago
Attachment #336865 - Flags: review?(bugzilla) → review+

Comment 14

10 years ago
Comment on attachment 336865 [details] [diff] [review]
[checked in] kill pref-winhooks

pushed removal of pref-winhooks as http://hg.mozilla.org/comm-central/rev/94c0142a32ac

Is that bug done now?
Attachment #336865 - Attachment description: kill pref-winhooks → [checked in] kill pref-winhooks
Blocks: 203644
Blocks: 255332
(Assignee)

Comment 15

10 years ago
(In reply to comment #6)
> (From update of attachment 336828 [details] [diff] [review])
> Is there a bug on fixing the wallpaper enabling code to check for the shell
> service instead?

Bug 454017.

(In reply to comment #14)
> (From update of attachment 336865 [details] [diff] [review])
> pushed removal of pref-winhooks as
> http://hg.mozilla.org/comm-central/rev/94c0142a32ac
> 
> Is that bug done now?

Yes.
Status: ASSIGNED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → FIXED
Target Milestone: --- → seamonkey2.0a1

Updated

9 years ago
Duplicate of this bug: 328473
Blocks: 52352

Comment 17

7 months ago
Pushed by frgrahl@gmx.net:
https://hg.mozilla.org/comm-central/rev/d417e8132c48
Winhooks commandline options won't work in suiterunner. r/sr=Neil
You need to log in before you can comment on or make changes to this bug.